airavata-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From machris...@apache.org
Subject [airavata-django-portal] branch master updated: Updating dependencies for vue-cli requirements
Date Thu, 17 Jan 2019 15:43:27 GMT
This is an automated email from the ASF dual-hosted git repository.

machristie pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/airavata-django-portal.git


The following commit(s) were added to refs/heads/master by this push:
     new bfda552  Updating dependencies for vue-cli requirements
bfda552 is described below

commit bfda5521f8e0dfe0e52428b19c899c990f47b598
Author: Marcus Christie <machrist@iu.edu>
AuthorDate: Thu Jan 17 10:20:26 2019 -0500

    Updating dependencies for vue-cli requirements
---
 django_airavata/apps/admin/package.json                      |  9 ++++++---
 django_airavata/apps/dataparsers/package.json                | 10 +++++++---
 django_airavata/apps/groups/package.json                     | 12 ++++++++----
 .../django-airavata-workspace-plugin-api/package.json        |  5 ++++-
 django_airavata/apps/workspace/package.json                  | 10 +++++++---
 django_airavata/static/common/package.json                   |  9 ++++++---
 6 files changed, 38 insertions(+), 17 deletions(-)

diff --git a/django_airavata/apps/admin/package.json b/django_airavata/apps/admin/package.json
index a611859..71a5d32 100644
--- a/django_airavata/apps/admin/package.json
+++ b/django_airavata/apps/admin/package.json
@@ -17,7 +17,7 @@
     "django-airavata-api": "file:../api",
     "django-airavata-common-ui": "file:../../static/common",
     "moment": "^2.22.2",
-    "vue": "^2.5.21",
+    "vue": "^2.5.22",
     "vue-resource": "^1.3.4",
     "vue-router": "^2.7.0",
     "vuedraggable": "^2.16.0",
@@ -29,8 +29,11 @@
     "@vue/cli-service": "^3.0.1",
     "@vue/component-compiler-utils": "^2.3.0",
     "autoprefixer": "^9.3.1",
-    "vue-template-compiler": "^2.5.21",
-    "webpack-bundle-tracker": "^0.3.0"
+    "vue-loader": "^15.5.1",
+    "vue-template-compiler": "^2.5.22",
+    "webpack": "^4.28.4",
+    "webpack-bundle-tracker": "^0.3.0",
+    "webpack-dev-middleware": "^3.5.0"
   },
   "eslintConfig": {
     "root": true,
diff --git a/django_airavata/apps/dataparsers/package.json b/django_airavata/apps/dataparsers/package.json
index 031b795..d94a902 100644
--- a/django_airavata/apps/dataparsers/package.json
+++ b/django_airavata/apps/dataparsers/package.json
@@ -15,7 +15,7 @@
     "bootstrap-vue": "^2.0.0-rc.11",
     "django-airavata-api": "file:../api",
     "django-airavata-common-ui": "file:../../static/common",
-    "vue": "^2.5.17"
+    "vue": "^2.5.22"
   },
   "devDependencies": {
     "@vue/cli-plugin-babel": "^3.1.1",
@@ -24,8 +24,12 @@
     "babel-eslint": "^10.0.1",
     "eslint": "^5.8.0",
     "eslint-plugin-vue": "^5.0.0-0",
-    "vue-template-compiler": "^2.5.21",
-    "webpack-bundle-tracker": "^0.4.2-beta"
+    "vue-loader": "^15.5.1",
+    "vue-template-compiler": "^2.5.22",
+    "webpack": "^4.28.4",
+    "webpack-bundle-tracker": "^0.4.2-beta",
+    "webpack-dev-middleware": "^3.5.1",
+    "webpack-dev-server": "^3.1.14"
   },
   "eslintConfig": {
     "root": true,
diff --git a/django_airavata/apps/groups/package.json b/django_airavata/apps/groups/package.json
index d77a85c..f3f75cd 100755
--- a/django_airavata/apps/groups/package.json
+++ b/django_airavata/apps/groups/package.json
@@ -12,11 +12,11 @@
   },
   "dependencies": {
     "bootstrap": "^4.0.0-beta.2",
-    "bootstrap-vue": "^1.0.2",
+    "bootstrap-vue": "^2.0.0-rc.11",
     "django-airavata-api": "file:../api",
     "django-airavata-common-ui": "file:../../static/common",
     "moment": "^2.18.1",
-    "vue": "^2.3.3"
+    "vue": "^2.5.22"
   },
   "devDependencies": {
     "@vue/cli-plugin-babel": "^3.1.1",
@@ -25,8 +25,12 @@
     "babel-eslint": "^10.0.1",
     "eslint": "^5.8.0",
     "eslint-plugin-vue": "^5.0.0-0",
-    "vue-template-compiler": "^2.5.21",
-    "webpack-bundle-tracker": "^0.4.2-beta"
+    "vue-loader": "^15.5.1",
+    "vue-template-compiler": "^2.5.22",
+    "webpack": "^4.28.4",
+    "webpack-bundle-tracker": "^0.4.2-beta",
+    "webpack-dev-middleware": "^3.5.1",
+    "webpack-dev-server": "^3.1.14"
   },
   "eslintConfig": {
     "root": true,
diff --git a/django_airavata/apps/workspace/django-airavata-workspace-plugin-api/package.json
b/django_airavata/apps/workspace/django-airavata-workspace-plugin-api/package.json
index d138337..bfe65ad 100644
--- a/django_airavata/apps/workspace/django-airavata-workspace-plugin-api/package.json
+++ b/django_airavata/apps/workspace/django-airavata-workspace-plugin-api/package.json
@@ -24,7 +24,10 @@
     "babel-eslint": "^10.0.1",
     "eslint": "^5.8.0",
     "eslint-plugin-vue": "^5.0.0-0",
-    "vue-template-compiler": "^2.5.17"
+    "vue-loader": "^15.5.1",
+    "vue-template-compiler": "^2.5.17",
+    "webpack": "^4.28.4",
+    "webpack-dev-middleware": "^3.5.1"
   },
   "eslintConfig": {
     "root": true,
diff --git a/django_airavata/apps/workspace/package.json b/django_airavata/apps/workspace/package.json
index 0554aac..be0c209 100644
--- a/django_airavata/apps/workspace/package.json
+++ b/django_airavata/apps/workspace/package.json
@@ -17,7 +17,7 @@
     "django-airavata-common-ui": "file:../../static/common",
     "django-airavata-workspace-plugin-api": "file:django-airavata-workspace-plugin-api",
     "moment": "^2.21.0",
-    "vue": "^2.5.21"
+    "vue": "^2.5.22"
   },
   "devDependencies": {
     "@vue/cli-plugin-babel": "^3.1.1",
@@ -26,8 +26,12 @@
     "babel-eslint": "^10.0.1",
     "eslint": "^5.8.0",
     "eslint-plugin-vue": "^5.0.0-0",
-    "vue-template-compiler": "^2.5.21",
-    "webpack-bundle-tracker": "^0.4.2-beta"
+    "vue-loader": "^15.5.1",
+    "vue-template-compiler": "^2.5.22",
+    "webpack": "^4.28.4",
+    "webpack-bundle-tracker": "^0.4.2-beta",
+    "webpack-dev-middleware": "^3.5.1",
+    "webpack-dev-server": "^3.1.14"
   },
   "eslintConfig": {
     "root": true,
diff --git a/django_airavata/static/common/package.json b/django_airavata/static/common/package.json
index cedd522..a3b3c28 100644
--- a/django_airavata/static/common/package.json
+++ b/django_airavata/static/common/package.json
@@ -18,7 +18,7 @@
     "django-airavata-api": "file:../../apps/api",
     "jquery": "^3.3.1",
     "popper.js": "^1.14.6",
-    "vue": "^2.5.21"
+    "vue": "^2.5.22"
   },
   "devDependencies": {
     "@vue/cli-plugin-babel": "^3.1.1",
@@ -29,8 +29,11 @@
     "eslint-plugin-vue": "^5.0.0-0",
     "node-sass": "^4.11.0",
     "sass-loader": "^7.1.0",
-    "vue-template-compiler": "^2.5.17",
-    "webpack-bundle-tracker": "^0.4.2-beta"
+    "vue-loader": "^15.5.1",
+    "vue-template-compiler": "^2.5.22",
+    "webpack": "^4.28.4",
+    "webpack-bundle-tracker": "^0.4.2-beta",
+    "webpack-dev-middleware": "^3.5.1"
   },
   "eslintConfig": {
     "root": true,


Mime
View raw message