airflow-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Guziel <alex.guz...@airbnb.com.INVALID>
Subject Re: Proposal: Set Celery 4.0 as a minimum as Celery 4 is unsupported
Date Tue, 19 Sep 2017 15:54:52 GMT
That's probably fine but I'd like to note two things.

1) The celery 3 config options are forwards compatible as far as I know
2) Still doesn't fix the bug where tasks get reserved even though it
shouldn't.


But I think it makes sense to upgrade the version in setup.py regardless.

On Tue, Sep 19, 2017 at 2:39 AM Bolke de Bruin <bdbruin@gmail.com> wrote:

> ping.
>
> I'd like some more feedback.
>
> Cheers
> Bolke
>
> Verstuurd vanaf mijn iPad
>
> > Op 16 sep. 2017 om 17:45 heeft Ash Berlin-Taylor <
> ash_airflowlist@firemirror.com> het volgende geschreven:
> >
> > +1 from us, we're running on Celery 4.0.2 in production on Airflow 1.8.2
> (4.1 wasn't out when we started and haven't upgraded in prod yet)
> >
> >
> >> On 16 Sep 2017, at 16:35, Bolke de Bruin <bdbruin@gmail.com> wrote:
> >>
> >> Hi,
> >>
> >> Some refactoring of the Celery config is underway and as some of the
> options have changed between Celery 3 and 4 I have asked the question
> whether Celery 3 is still supported. Apparently it is not (
> https://github.com/celery/celery/issues/4258 <
> https://github.com/celery/celery/issues/4258>).
> >>
> >> As Celery 3 is also 2 major releases behind I propose to set Celery 4.0
> as a minimum supported version with Celery 4.1 being the recommend version.
> I think this is also important as we do see some intermittent issues with
> Celery that are reported to us but are, most likely, issues in Celery. I
> don’t want to take care of those as they are difficult to debug.
> >>
> >> I would like to do this per 1.9.0. The 1.8.X branch can still support
> Celery 3.
> >>
> >> Cheers
> >> Bolke
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message