allura-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kentontay...@apache.org
Subject [allura] 03/04: [#8311] move transitive deps out of requirements.in
Date Wed, 10 Jul 2019 20:03:41 GMT
This is an automated email from the ASF dual-hosted git repository.

kentontaylor pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/allura.git

commit 88639a2e23d4d885411142684572ac31542ae329
Author: Dave Brondsema <dave@brondsema.net>
AuthorDate: Wed Jun 26 18:17:00 2019 -0400

    [#8311] move transitive deps out of requirements.in
---
 requirements.in  | 38 +-------------------------------------
 requirements.txt | 48 +++++++++++++++++++++++-------------------------
 2 files changed, 24 insertions(+), 62 deletions(-)

diff --git a/requirements.in b/requirements.in
index 2abca4c..de7464a 100644
--- a/requirements.in
+++ b/requirements.in
@@ -5,21 +5,12 @@ Beaker==1.6.4
 bleach==3.1.0
 chardet==1.0.1
 colander==1.7.0
-# dep of pypeline
-Creoleparser==0.7.5
 decorator==3.3.2
-# dep of pypeline, sphinx
 EasyWidgets==0.3.2
-docutils==0.14
 faulthandler==2.1
 feedparser==5.1.3
 FormEncode==1.2.4
-# dep of Creoleparser
-Genshi==0.7.3
 html5lib==1.0.1
-# dep of oauth2
-httplib2==0.7.4
-iso8601==0.1.12
 Jinja2==2.10
 Markdown==2.2.1
 Ming==0.5.6
@@ -31,7 +22,7 @@ Pillow==5.2.0
 poster==0.8.1
 Pygments==2.2.0
 pymongo==2.8.1
-Pypeline==0.5
+Pypeline[creole,markdown,textile,rst]==0.5
 pysolr==3.6.0
 python-dateutil==1.5
 python-magic==0.4.3
@@ -39,44 +30,21 @@ python-oembed==0.2.1
 pytz==2014.10
 qrcode==5.3
 requests==2.11.1
-oauthlib==0.4.2
 requests-oauthlib==0.4.0
 # for taskd proc name switching
 setproctitle==1.1.9
 six==1.12.0
-# dep of pypeline
-textile==3.0.4
-# dep of colander
-translationstring==1.3
 TimerMiddleware==0.5.0
 TurboGears2==2.3.12
-# dep of html5lib
-webencodings==0.5.1
 WebOb==1.7.4
 
-# dependencies for cryptography
 cryptography==2.6.1
-# loose spec for setuptools since it is a very base package; but cryptography needs it past
a certain version
-setuptools>=11.3
-cffi==1.12.2
-pycparser==2.19
-enum34==1.1.6
-ipaddress==1.0.22
-asn1crypto==0.24.0
 
-# tg2 deps (not used directly)
-Babel==1.3
 backlash==0.1.4
-crank==0.8.1
-Mako==1.0.7
 MarkupSafe==1.0
-repoze.lru==0.7
 WebHelpers==1.3
 
-# git deps
 GitPython==2.1.11
-gitdb2==2.0.4
-smmap2==2.0.4
 
 # testing & development
 datadiff==1.1.5
@@ -87,10 +55,6 @@ pyflakes==0.8.1
 WebTest==2.0.33
 testfixtures==3.0.0
 pylint==1.4.4
-# setup dep of Textile
-pytest-runner==5.1
-astroid==1.3.8
-logilab-common==1.0.2
 q==2.3
 sphinx-argparse==0.2.5
 sphinx-rtd-theme==0.1.6
diff --git a/requirements.txt b/requirements.txt
index f0c0827..51adf17 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -6,43 +6,42 @@
 #
 activitystream==0.2.2
 alabaster==0.7.12         # via sphinx
-asn1crypto==0.24.0
-astroid==1.3.8
-babel==1.3
+asn1crypto==0.24.0        # via cryptography
+astroid==1.3.8            # via pylint
+babel==1.3                # via sphinx
 backlash==0.1.4
 beaker==1.6.4
 beautifulsoup4==4.6.1
 beautifulsoup==3.2.0
 bleach==3.1.0
-cffi==1.12.2
+cffi==1.12.2              # via cryptography
 chardet==1.0.1
 colander==1.7.0
-crank==0.8.1
-creoleparser==0.7.5
+crank==0.8.1              # via turbogears2
+creoleparser==0.7.5       # via pypeline
 cryptography==2.6.1
 datadiff==1.1.5
 decorator==3.3.2
-docutils==0.14
+docutils==0.14            # via pypeline, sphinx
 easywidgets==0.3.2
 emoji==0.5.1
-enum34==1.1.6
+enum34==1.1.6             # via colander, cryptography
 faulthandler==2.1
 feedparser==5.1.3
 formencode==1.2.4
 future==0.17.1            # via timermiddleware
-genshi==0.7.3
-gitdb2==2.0.4
+genshi==0.7.3             # via creoleparser
+gitdb2==2.0.4             # via gitpython
 gitpython==2.1.11
 gunicorn==19.4.5
 html5lib==1.0.1
-httplib2==0.7.4
+httplib2==0.7.4           # via oauth2
 imagesize==1.1.0          # via sphinx
-ipaddress==1.0.22
+ipaddress==1.0.22         # via cryptography
 ipython==1.2.1
-iso8601==0.1.12
+iso8601==0.1.12           # via colander
 jinja2==2.10
-logilab-common==1.0.2
-mako==1.0.7
+logilab-common==1.0.2     # via astroid, pylint
 markdown-checklist==0.4.1
 markdown==2.2.1
 markupsafe==1.0
@@ -50,34 +49,33 @@ ming==0.5.6
 mock==1.0.1
 nose==1.3.4
 oauth2==1.5.170
-oauthlib==0.4.2
+oauthlib==0.4.2           # via requests-oauthlib
 packaging==19.0           # via sphinx
 paste==3.0.1
 pastedeploy==1.5.2
 pastescript==2.0.2
 pillow==5.2.0
 poster==0.8.1
-pycparser==2.19
+pycparser==2.19           # via cffi
 pyflakes==0.8.1
 pygments==2.2.0
 pylint==1.4.4
 pymongo==2.8.1
 pyparsing==2.4.0          # via packaging
-pypeline==0.5
+pypeline[creole,markdown,rst,textile]==0.5
 pysolr==3.6.0
-pytest-runner==5.1
 python-dateutil==1.5
 python-magic==0.4.3
 python-oembed==0.2.1
 pytz==2014.10
 q==2.3
 qrcode==5.3
-repoze.lru==0.7
+repoze.lru==0.7           # via turbogears2
 requests-oauthlib==0.4.0
 requests==2.11.1
 setproctitle==1.1.9
 six==1.12.0
-smmap2==2.0.4
+smmap2==2.0.4             # via gitdb2
 snowballstemmer==1.9.0    # via sphinx
 sphinx-argparse==0.2.5
 sphinx-rtd-theme==0.1.6
@@ -85,16 +83,16 @@ sphinx==1.8.5             # via sphinx-argparse, sphinx-rtd-theme, sphinxcontrib
 sphinxcontrib-programoutput==0.8
 sphinxcontrib-websupport==1.1.2  # via sphinx
 testfixtures==3.0.0
-textile==3.0.4
+textile==3.0.4            # via pypeline
 timermiddleware==0.5.0
-translationstring==1.3
+translationstring==1.3    # via colander
 turbogears2==2.3.12
 typing==3.7.4             # via sphinx
 waitress==1.3.0           # via webtest
-webencodings==0.5.1
+webencodings==0.5.1       # via bleach, html5lib
 webhelpers==1.3
 webob==1.7.4
 webtest==2.0.33
 
 # The following packages are considered to be unsafe in a requirements file:
-# setuptools==41.0.1
+# setuptools==41.0.1        # via logilab-common, sphinx


Mime
View raw message