allura-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From brond...@apache.org
Subject [allura] 04/06: [#8320] Upgrade pylint and deps
Date Tue, 30 Jul 2019 21:17:06 GMT
This is an automated email from the ASF dual-hosted git repository.

brondsem pushed a commit to branch db/8320
in repository https://gitbox.apache.org/repos/asf/allura.git

commit 6fb164bff8e61fc6662552bf7931df62a865825d
Author: Dave Brondsema <dave@brondsema.net>
AuthorDate: Fri Jul 19 18:12:31 2019 -0400

    [#8320] Upgrade pylint and deps
---
 requirements-dev.txt | 16 +++++++++++-----
 requirements.in      |  2 +-
 requirements.txt     | 17 ++++++++++-------
 3 files changed, 22 insertions(+), 13 deletions(-)

diff --git a/requirements-dev.txt b/requirements-dev.txt
index a226a62..a8ad534 100644
--- a/requirements-dev.txt
+++ b/requirements-dev.txt
@@ -7,9 +7,10 @@
 activitystream==0.2.2
 alabaster==0.7.12         # via sphinx
 asn1crypto==0.24.0        # via cryptography
-astroid==1.3.8            # via pylint
+astroid==1.6.6            # via pylint
 babel==2.7.0              # via sphinx
 backlash==0.1.4
+backports.functools-lru-cache==1.5  # via astroid, isort, pylint
 beaker==1.10.1
 beautifulsoup4==4.6.1
 beautifulsoup==3.2.0
@@ -18,6 +19,7 @@ cffi==1.12.2              # via cryptography
 chardet==3.0.4
 click==7.0                # via pip-tools
 colander==1.7.0
+configparser==3.7.4       # via pylint
 crank==0.8.1              # via turbogears2
 creoleparser==0.7.5       # via pypeline
 cryptography==2.6.1
@@ -26,12 +28,13 @@ decorator==4.4.0
 docutils==0.14            # via pypeline, sphinx
 easywidgets==0.3.2
 emoji==0.5.1
-enum34==1.1.6             # via colander, cryptography
+enum34==1.1.6             # via astroid, colander, cryptography
 faulthandler==2.1
 feedparser==5.1.3
 formencode==1.2.4
 funcsigs==1.0.2           # via beaker
 future==0.17.1            # via timermiddleware
+futures==3.3.0            # via isort
 genshi==0.7.3             # via creoleparser
 gitdb2==2.0.4             # via gitpython
 gitpython==2.1.11
@@ -42,11 +45,13 @@ imagesize==1.1.0          # via sphinx
 ipaddress==1.0.22         # via cryptography
 ipython==1.2.1
 iso8601==0.1.12           # via colander
+isort==4.3.21             # via pylint
 jinja2==2.10
-logilab-common==1.0.2     # via astroid, pylint
+lazy-object-proxy==1.4.1  # via astroid
 markdown-checklist==0.4.1
 markdown==2.2.1
 markupsafe==1.0
+mccabe==0.6.1             # via pylint
 ming==0.5.6
 mock==1.0.1
 nose==1.3.4
@@ -62,7 +67,7 @@ poster==0.8.1
 pycparser==2.19           # via cffi
 pyflakes==0.8.1
 pygments==2.2.0
-pylint==1.4.4
+pylint==1.9.5
 pymongo==2.8.1
 pyparsing==2.4.0          # via packaging
 pypeline[creole,markdown,rst,textile]==0.5
@@ -77,6 +82,7 @@ repoze.lru==0.7           # via turbogears2
 requests-oauthlib==0.4.0
 requests==2.11.1
 setproctitle==1.1.9
+singledispatch==3.4.0.3   # via astroid, pylint
 six==1.12.0
 smmap2==2.0.4             # via gitdb2
 snowballstemmer==1.9.0    # via sphinx
@@ -99,4 +105,4 @@ webtest==2.0.33
 wrapt==1.11.2
 
 # The following packages are considered to be unsafe in a requirements file:
-# setuptools==41.0.1        # via logilab-common, sphinx
+# setuptools==41.0.1        # via sphinx
diff --git a/requirements.in b/requirements.in
index 57180a9..53c34e3 100644
--- a/requirements.in
+++ b/requirements.in
@@ -51,7 +51,7 @@ mock==1.0.1
 nose==1.3.4
 poster==0.8.1
 pyflakes==0.8.1
-pylint==1.4.4
+pylint
 testfixtures==3.0.0
 WebTest==2.0.33
 
diff --git a/requirements.txt b/requirements.txt
index 245c8ce..439028d 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -6,8 +6,9 @@
 #
 activitystream==0.2.2
 asn1crypto==0.24.0        # via cryptography
-astroid==1.3.8            # via pylint
+astroid==1.6.6            # via pylint
 backlash==0.1.4
+backports.functools-lru-cache==1.5  # via astroid, isort, pylint
 beaker==1.10.1
 beautifulsoup4==4.6.1
 beautifulsoup==3.2.0
@@ -15,6 +16,7 @@ bleach==3.1.0             # via pypeline
 cffi==1.12.2              # via cryptography
 chardet==3.0.4
 colander==1.7.0
+configparser==3.7.4       # via pylint
 crank==0.8.1              # via turbogears2
 creoleparser==0.7.5       # via pypeline
 cryptography==2.6.1
@@ -23,12 +25,13 @@ decorator==4.4.0
 docutils==0.14            # via pypeline
 easywidgets==0.3.2
 emoji==0.5.1
-enum34==1.1.6             # via colander, cryptography
+enum34==1.1.6             # via astroid, colander, cryptography
 faulthandler==2.1
 feedparser==5.1.3
 formencode==1.2.4
 funcsigs==1.0.2           # via beaker
 future==0.17.1            # via timermiddleware
+futures==3.3.0            # via isort
 genshi==0.7.3             # via creoleparser
 gitdb2==2.0.4             # via gitpython
 gitpython==2.1.11
@@ -38,11 +41,13 @@ httplib2==0.7.4           # via oauth2
 ipaddress==1.0.22         # via cryptography
 ipython==1.2.1
 iso8601==0.1.12           # via colander
+isort==4.3.21             # via pylint
 jinja2==2.10
-logilab-common==1.0.2     # via astroid, pylint
+lazy-object-proxy==1.4.1  # via astroid
 markdown-checklist==0.4.1
 markdown==2.2.1
 markupsafe==1.0
+mccabe==0.6.1             # via pylint
 ming==0.5.6
 mock==1.0.1
 nose==1.3.4
@@ -56,7 +61,7 @@ poster==0.8.1
 pycparser==2.19           # via cffi
 pyflakes==0.8.1
 pygments==2.2.0
-pylint==1.4.4
+pylint==1.9.5
 pymongo==2.8.1
 pypeline[creole,markdown,rst,textile]==0.5
 pysolr==3.6.0
@@ -69,6 +74,7 @@ repoze.lru==0.7           # via turbogears2
 requests-oauthlib==0.4.0
 requests==2.11.1
 setproctitle==1.1.9
+singledispatch==3.4.0.3   # via astroid, pylint
 six==1.12.0
 smmap2==2.0.4             # via gitdb2
 testfixtures==3.0.0
@@ -82,6 +88,3 @@ webhelpers==1.3
 webob==1.7.4
 webtest==2.0.33
 wrapt==1.11.2
-
-# The following packages are considered to be unsafe in a requirements file:
-# setuptools==41.0.1        # via logilab-common


Mime
View raw message