allura-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From brond...@apache.org
Subject [allura] 13/14: [#8320] upgrade ipython
Date Wed, 31 Jul 2019 20:41:29 GMT
This is an automated email from the ASF dual-hosted git repository.

brondsem pushed a commit to branch db/8320
in repository https://gitbox.apache.org/repos/asf/allura.git

commit 5bebfedc837f754e4ee5c643b6b2ff4c03530421
Author: Dave Brondsema <dave@brondsema.net>
AuthorDate: Wed Jul 31 15:26:38 2019 -0400

    [#8320] upgrade ipython
---
 requirements.in  |  2 +-
 requirements.txt | 19 +++++++++++++++++--
 2 files changed, 18 insertions(+), 3 deletions(-)

diff --git a/requirements.in b/requirements.in
index 52f5f7d..e96b209 100644
--- a/requirements.in
+++ b/requirements.in
@@ -47,7 +47,7 @@ wrapt==1.11.2
 
 # testing
 datadiff
-ipython==1.2.1
+ipython<6  # Ipython 7 starts to require py3
 mock
 nose==1.3.4
 poster==0.8.1
diff --git a/requirements.txt b/requirements.txt
index e045210..864cb05 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -5,10 +5,12 @@
 #    pip-compile
 #
 activitystream==0.2.2
+appnope==0.1.0            # via ipython
 asn1crypto==0.24.0        # via cryptography
 astroid==1.6.6            # via pylint
 backlash==0.1.4
 backports.functools-lru-cache==1.5  # via astroid, isort, pylint
+backports.shutil-get-terminal-size==1.0.0  # via ipython
 beaker==1.10.1
 beautifulsoup4==4.6.1
 beautifulsoup==3.2.0
@@ -26,7 +28,7 @@ decorator==4.4.0
 docutils==0.14            # via pypeline
 easywidgets==0.3.2
 emoji==0.5.1
-enum34==1.1.6             # via astroid, colander, cryptography
+enum34==1.1.6             # via astroid, colander, cryptography, traitlets
 faulthandler==3.1
 feedparser==5.1.3
 formencode==1.2.4
@@ -41,7 +43,8 @@ html5lib==1.0.1
 httplib2==0.13.1          # via oauth2
 idna==2.8                 # via requests
 ipaddress==1.0.22         # via cryptography
-ipython==1.2.1
+ipython-genutils==0.2.0   # via traitlets
+ipython==5.8.0
 iso8601==0.1.12           # via colander
 isort==4.3.21             # via pylint
 jinja2==2.10
@@ -58,8 +61,13 @@ oauthlib==3.0.2           # via requests-oauthlib
 paste==3.0.1
 pastedeploy==1.5.2
 pastescript==2.0.2
+pathlib2==2.3.4           # via ipython, pickleshare
+pexpect==4.7.0            # via ipython
+pickleshare==0.7.5        # via ipython
 pillow==5.2.0
 poster==0.8.1
+prompt-toolkit==1.0.16    # via ipython
+ptyprocess==0.6.0         # via pexpect
 pycparser==2.19           # via cffi
 pyflakes==2.1.1
 pygments==2.2.0
@@ -75,19 +83,26 @@ qrcode==5.3
 repoze.lru==0.7           # via turbogears2
 requests-oauthlib==1.2.0
 requests==2.22.0
+scandir==1.10.0           # via pathlib2
 setproctitle==1.1.9
+simplegeneric==0.8.1      # via ipython
 singledispatch==3.4.0.3   # via astroid, pylint
 six==1.12.0
 smmap2==2.0.4             # via gitdb2
 testfixtures==6.10.0
 textile==3.0.4            # via pypeline
 timermiddleware==0.5.0
+traitlets==4.3.2          # via ipython
 translationstring==1.3    # via colander
 turbogears2==2.3.12
 urllib3==1.25.3           # via requests
 waitress==1.3.0           # via webtest
+wcwidth==0.1.7            # via prompt-toolkit
 webencodings==0.5.1       # via bleach, html5lib
 webhelpers==1.3
 webob==1.7.4
 webtest==2.0.33
 wrapt==1.11.2
+
+# The following packages are considered to be unsafe in a requirements file:
+# setuptools==41.0.1        # via ipython


Mime
View raw message