allura-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kentontay...@apache.org
Subject [allura] 07/18: [#8320] stop including all of req.in/txt within req-dev.in/txt
Date Mon, 05 Aug 2019 18:27:35 GMT
This is an automated email from the ASF dual-hosted git repository.

kentontaylor pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/allura.git

commit 8e2b694668f31a2bf7225a62bb781459965fbec6
Author: Dave Brondsema <dave@brondsema.net>
AuthorDate: Wed Jul 31 11:11:08 2019 -0400

    [#8320] stop including all of req.in/txt within req-dev.in/txt
    
    It was becoming quite annoying to have to recompile req.txt and req-dev.txt
    every time a package was updated.  Now you should run "pip-sync" or "pip
    install -r" with both req.txt and req-dev.txt filenames at the same time.
---
 requirements-dev.in  |  2 --
 requirements-dev.txt | 91 ++++------------------------------------------------
 2 files changed, 7 insertions(+), 86 deletions(-)

diff --git a/requirements-dev.in b/requirements-dev.in
index 68bc62e..c1e7257 100644
--- a/requirements-dev.in
+++ b/requirements-dev.in
@@ -1,5 +1,3 @@
--r requirements.in
-
 # development-only dependencies
 # nothing needed at runtime or for tests
 
diff --git a/requirements-dev.txt b/requirements-dev.txt
index 8bdda91..6a57d20 100644
--- a/requirements-dev.txt
+++ b/requirements-dev.txt
@@ -4,105 +4,28 @@
 #
 #    pip-compile requirements-dev.in
 #
-activitystream==0.2.2
 alabaster==0.7.12         # via sphinx
-asn1crypto==0.24.0        # via cryptography
-astroid==1.6.6            # via pylint
 babel==2.7.0              # via sphinx
-backlash==0.1.4
-backports.functools-lru-cache==1.5  # via astroid, isort, pylint
-beaker==1.10.1
-beautifulsoup4==4.6.1
-beautifulsoup==3.2.0
-bleach==3.1.0             # via pypeline
-cffi==1.12.2              # via cryptography
-chardet==3.0.4
 click==7.0                # via pip-tools
-colander==1.7.0
-configparser==3.7.4       # via pylint
-crank==0.8.1              # via turbogears2
-creoleparser==0.7.5       # via pypeline
-cryptography==2.6.1
-datadiff==1.1.5
-decorator==4.4.0
-docutils==0.14            # via pypeline, sphinx
-easywidgets==0.3.2
-emoji==0.5.1
-enum34==1.1.6             # via astroid, colander, cryptography
-faulthandler==2.1
-feedparser==5.1.3
-formencode==1.2.4
-funcsigs==1.0.2           # via beaker
-future==0.17.1            # via timermiddleware
-futures==3.3.0            # via isort
-genshi==0.7.3             # via creoleparser
-gitdb2==2.0.4             # via gitpython
-gitpython==2.1.11
-gunicorn==19.4.5
-html5lib==1.0.1
-httplib2==0.7.4           # via oauth2
+docutils==0.14            # via sphinx
 imagesize==1.1.0          # via sphinx
-ipaddress==1.0.22         # via cryptography
-ipython==1.2.1
-iso8601==0.1.12           # via colander
-isort==4.3.21             # via pylint
-jinja2==2.10
-lazy-object-proxy==1.4.1  # via astroid
-markdown-checklist==0.4.1
-markdown==2.2.1
-markupsafe==1.0
-mccabe==0.6.1             # via pylint
-ming==0.5.6
-mock==1.0.1
-nose==1.3.4
-oauth2==1.5.170
-oauthlib==0.4.2           # via requests-oauthlib
+jinja2==2.10              # via sphinx
+markupsafe==1.0           # via jinja2
 packaging==19.0           # via sphinx
-paste==3.0.1
-pastedeploy==1.5.2
-pastescript==2.0.2
-pillow==5.2.0
 pip-tools==3.8.0
-poster==0.8.1
-pycparser==2.19           # via cffi
-pyflakes==2.1.1
-pygments==2.2.0
-pylint==1.9.5
-pymongo==2.8.1
+pygments==2.2.0           # via sphinx
 pyparsing==2.4.0          # via packaging
-pypeline[creole,markdown,rst,textile]==0.5
-pysolr==3.6.0
-python-dateutil==2.8.0
-python-magic==0.4.3
-python-oembed==0.2.1
-pytz==2019.1
+pytz==2019.1              # via babel
 q==2.3
-qrcode==5.3
-repoze.lru==0.7           # via turbogears2
-requests-oauthlib==0.4.0
-requests==2.11.1
-setproctitle==1.1.9
-singledispatch==3.4.0.3   # via astroid, pylint
-six==1.12.0
-smmap2==2.0.4             # via gitdb2
+requests==2.11.1          # via sphinx
+six==1.12.0               # via packaging, pip-tools, sphinx
 snowballstemmer==1.9.0    # via sphinx
 sphinx-argparse==0.2.5
 sphinx-rtd-theme==0.1.6
 sphinx==1.8.5             # via sphinx-argparse, sphinx-rtd-theme, sphinxcontrib-programoutput
 sphinxcontrib-programoutput==0.8
 sphinxcontrib-websupport==1.1.2  # via sphinx
-testfixtures==3.0.0
-textile==3.0.4            # via pypeline
-timermiddleware==0.5.0
-translationstring==1.3    # via colander
-turbogears2==2.3.12
 typing==3.7.4             # via sphinx
-waitress==1.3.0           # via webtest
-webencodings==0.5.1       # via bleach, html5lib
-webhelpers==1.3
-webob==1.7.4
-webtest==2.0.33
-wrapt==1.11.2
 
 # The following packages are considered to be unsafe in a requirements file:
 # setuptools==41.0.1        # via sphinx


Mime
View raw message