ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Mawson <>
Subject Javac task does not find dependant classes
Date Thu, 01 Jan 1970 00:00:00 GMT

I am using Ant nightly build from 10 August.

In my project I call are a number of javac tasks successfully. When I get
to one particular javac task (which has over 1000 classes to compile) it
falls over because one particular class being compiled calls a constructor
from within a third party library (in zip format) and the compiler believes
that this particular constructor is unknown.

Here comes the weird part. The zip file *is* in the classpath. The
signature of the constructor *is* correct. The class *does* compile from
the command line with the same environment. I tried modifying the
classpath:  I shuffled the zip to the *front* of the classpath. I tried
unzipping the library into the classpath. I tried cutting and pasting the
classpath from my command line environment. Nothing has worked -- yet!

I understand there have been changes to how the javac task hadles large
batches of classes since 10-Aug, so I am about to try the latest build.
However, if anyone else has advice for me I'll be glad to hear it.

Here's the relevant ant call (slightly obfuscated):

	<property name="CLASSPATH"            




    <target name="compileCore">
		<mkdir dir="${CLASSES_BUILD_DIR}/something" />
		   excludes="**/exclude01*/, **/, **/" />


View raw message