ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anuj Agrawal <>
Subject Re: FTP and remote subdirs
Date Fri, 06 Apr 2001 11:20:26 GMT
<!doctype html public "-//w3c//dtd html 4.0 transitional//en">
<body bgcolor="#FFFFFF">
We had the same problem.&nbsp; So we looked into the source and found a
problem.&nbsp; We fixed it, but were not sure how to submit the patch.
8((( .. i could be wrong, but i thought i remembered reading another thread
that indicated that someone else had submitted a patch. *shrug* .. i'd
be happy to send you the code if you want (or submit it as a patch, if
i knew how).. let me know..
<p>Paul Dillon wrote:
<blockquote TYPE=CITE><font face="Arial"><font size=-1>I can not get the
ftp task to delve into sub-directories on the remote server.&nbsp; In particular,
I am trying to delete all files below a directory, as follows:</font></font>&nbsp;<font
face="Arial"><font size=-1>&lt;ftp
server="${deploy.server}" userid="${deploy.user}" password="${deploy.password}"
remotedir="${deploy.dir}" action="del"></font></font><font face="Arial"><font
&lt;fileset></font></font><font face="Arial"><font size=-1>&nbsp;&nbsp;&nbsp;
&lt;include name="**/*"/></font></font>
<br><font face="Arial"><font size=-1>&nbsp; &lt;/fileset></font></font><font
face="Arial"><font size=-1>&lt;/ftp></font></font>&nbsp;<font
face="Arial"><font size=-1>I've
tried a billion different combinations of fileset, under no circumstance
does the ftp task ever go into sub directories.&nbsp; This is also true
for the list action - I can only ever list files in the starting directory.</font></font></blockquote>


View raw message