ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Burch" <>
Subject Re: Antwort: Odd Behaviour ...
Date Tue, 29 Jan 2002 09:41:10 GMT
I had a similar problem when I'd just started using ant. I suspected I would not get
a lot of sympathy from the community because I was using OS2. I spent a lot of time
investigating and eventually found a helpful posting much earlier in the archive.
X-Spam-Rating: 1.6.2 0/1000/N
X-Spam-Rating: 1.6.2 0/1000/N

I had exactly the same symptoms. I was using my own execution environment,
rather than the MS-Dos ant.bat file. Unlike jdk 1.1, most of the javac compiler in
jdk 1.3 is found in the tools.jar file. The problem was solved by "simply" adding
the jar to my ant execution classpath.

While I (grin) derived great benefit from the learning experience, it seems to me
that the error message is no longer appropriate to the post-jdk-1.1 era. Perhaps
one of the developers could update the message?

BTW, I searched the faq when working on this problem. If I (and others)
missed finding the answer there, could it be made easier to find?

I agree strongly with Eric. I spent too many years working on cross-platform
C projects trying to maintain a workable/portable make environment. I was
delighted to see how "easy" it was to migrate my java projects to Ant under
OS2 jdk 1.1 and 1.3, as well as the sun jdk on NT. Ant is wonderful, but it isn't
claiming to be perfect. It's always a good idea to wonder what you've got wrong
in your environment before thinking you've found a bug or a deficiency - whatever
product you are using...

On Mon, 28 Jan 2002 21:17:56 -0500, Erik Hatcher wrote:

>The developers are here listening.  And for it being unacceptable behavior -
>I'd agree with you except that thousands (millions?) of Ant users have
>successfully used Ant with JDK 1.3 all over the world. Rather than blaming
>Ant for something that is obviously a configuration or environment problem
>on your machine - how about giving us some more details of the problem like
>your build.xml file and the complete 'ant -debug' output?
>> Hi Hauke,
>> No sorry but the advice did not work. The system could not find
>> either the "classic" or the "modern compilers, and therefore the
>> build kept failing. I think this is unacceptable behaviour for
>> a tool like "ant", but I don't understand it. I solved the problem
>> by installing jikes and setting build.compiler="jikes". But this
>> does not shed light on what the real problem was. Perhaps I should
>> ask the developers.
>> Thanks
>> Regards
>> goffredo
>> >
>> > Hi
>> > I'm trying to do a build. I have JDK 1.3 and JAVA_HOME is
>> > set to c:\jdk1.3. But the build fails with the odd message,
>> > Java classic not found, suggest you set JAVA_HOME. What?
>> > I assume that ant requires some kind of VM before it can
>> > run ... that VM should be by default the one it uses to run
>> > javac ... What on earth is goin on?


Brian Burch

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message