ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Raible" <>
Subject RE: SOLVED - Ant doesn't recognized tasks on Mac OS X
Date Thu, 17 Jan 2002 14:23:43 GMT
I got a response from the Apple Java group - the solutions worked.

I simply copied all the jar files from ANT_HOME/lib to
/Library/Java/Extensions and then moved ANT_HOME/bin/ant to ~/bin


-----Original Message-----
From: Conor MacNeill []
Sent: Wednesday, January 16, 2002 10:11 PM
To: Ant Users List;
Subject: RE: Ant doesn't recognized tasks on Mac OS X

> From: Matt Raible []
> Sent: Thursday, 17 January 2002 3:36 PM
> To:
> Subject: Ant doesn't recognized tasks on Mac OS X
> Please respond to, as I am not subscribed
> to this list.
> I've downloaded and installed Ant 1.4.1 on OS X system.  It seems
> to work fine,
> but I cannot pass in any commands - only the default task gets executed.
> For instance, if my default task is "compile", and I type "ant
> clean" on the
> command line, "compile" gets executed.
> Any ideas?

You could try editing the script used to launch Ant and see what command
line it ends up constructing to run the main Ant class. You should be able
to throw an echo in there, somewhere. Let us know the result.


To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message