ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "*" <>
Subject Re: Installing Ant on WinMe
Date Thu, 22 Jan 2004 16:38:02 GMT
Hi Chip,
Thanks for your prompt reply to my questions.
Perhaps I should throw the b*st*rd out and start again?
It's strange that I can use the Ant which was installed with Eclipse, but
not the stand alone product. I'm sure that there is just some small gotcha
fouling up the works.
Thanks again,

----- Original Message -----
From: "Chip Dunning" <>
To: "Ant Users List" <>
Sent: Thursday, January 22, 2004 4:49 PM
Subject: RE: Installing Ant on WinMe

Fortunately I ditched my only WinME machines within days of that virus
infecting them, but I do understand your pain. However, I keep an cheapo
machine with Me just so that I can test my software. I just Ant 1.5 on it
and did not see any errors. The scripts ran just fine - couldn't use my CVS
scripts since I don't allow Me on my network, but I did various cleaning out
of directories, javac builds, jar making, javadoc creation, and finally
deployment to a different directory.
I would treat Me more like it is XP/2000 than 9x. I understand that Me was a
bit of a b*st*rd child that nobody wanted, but some of the core is close
enough. My machine hasn't been upgraded in quite some time, so it could be a
Microsoft patch/hotfix that is causing your problem. It is a really cheap
stock PC with only Windows ME, Sun Java 1.4, Ant 1.5, Eclipse2 (with
checkstyle and PMD plugins), and bits and pieces of my own code scattered

I wish I could help more, but I never saw the error you are describing.

"The enemy of my enemy is convenient."

-----Original Message-----
From: * []
Sent: Thursday, January 22, 2004 9:19 AM
To: Ant Users List
Subject: Installing Ant on WinMe

Hi all,
I am having difficulty in installing Ant 1.6 on a WinMe machine. The Ant
manual assumes that Win9x, NT behave the same as WinMe, which is not the
case. Some help is much needed here!
I get an "Out Of Environment Space" error a few times and then a "Bad file
name" error, when calling ant.bat.
The Ant manual suggests adding 'shell=c:\ c:\ /p /e:32768' to the
config.sys file, but on WinMe there is no config.sys file - see M$ knowledge
base article at
Any Dos environment changes which are required should apparently be made in
a cmdinit.bat file, which is run each time the Dos window is called from
Adding the shell=entry line to this batch file, however,  has not made any
difference to my install problem.
I will be grateful to find someone out there who can help?

I have tried with Ant1.5 with the same result, so I don't think it's the
version of Ant.


To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message