ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nikola Banovic" <>
Subject RE: CVS Task Fails To Execute
Date Sat, 21 Aug 2004 22:58:20 GMT

The path to the CVS client executable file is set. But I just want to make
sure that we are talking about the environment variable named PATH. I'm able
to execute the CVS client from the command prompt (any working folder) by
just typing: cvs.

Is there a path I have to set that is specific to Ant? Can it be that there
is another resource missing?


-----Original Message-----
From: Antoine Levy-Lambert []
Sent: Saturday, August 21, 2004 10:50 AM
To: Ant Users List
Subject: Re: CVS Task Fails To Execute

Hi Nikola,

can it be that cvs.exe is simply not on the path ?
Sorry, this should have been the first thing to check,


Nikola Banovic wrote:

>Thanks for your reply.
>I tried your suggestions, however I still have the same problem. I even
>compiled an executable (a version of the batch file), but it didn't work.
>appears that it is the CVS client that is not getting called since it
>doesn't even start the executable file that calls plink.exe.
>I got rid of both batch file and executable file and now my CVS_RSH is set
>to plink.exe only (full path to it, just in case).
>You asked me if I can run CVS using the CVS_RSH from command line. Yes, I
>can. I've never had that problem.
>Can you please tell me what CVS related environment variables you have set
>and what those values mean.
>Is there anybody out there with a similar problem?
>-----Original Message-----
>From: Antoine Levy-Lambert []
>Sent: Tuesday, August 17, 2004 11:36 AM
>Subject: Re: CVS Task Fails To Execute
>Maybe you should try to set CVS_RSH to something like "CMD /C batch_script"
>or maybe this won't even work, and you need to compile somehow an
>which does what you want.
>Your problem might be that a batch script is not an executable, only
>/c batch_script is.
>you might want to add echo %* >> C:\temp\logfile.txt in your batch to find
>out whether the batch is reached by cvs.exe.
>Other question : can you run cvs from the command line using your CVS_RSH
>value ?
>>When I try to access a CVS repository I get the following error:
>>[cvs] Caught exception: CreateProcess:
>>cvs -d:ext:me@anIP:/path/to/aRepository checkout -r r1_0_0 aModule
>>The unusual part of it is that the cvs.exe file is in the path (I can
>>checkout files if I copy and paste the command in the command prompt).
>>I'm running CVS client that comes with cvsnt 2.0.51 on Win2000. The
>>system variable is set to a batch script (it is set to a full path of the
>>script file) that calls PuTTY's plink.exe (also full path) with
>>arguments. The following is content of the batch file:
>>@echo off
>>if ""%1""=="""" goto doneSetArgs
>>goto setArgs
>>"C:\Program Files\PuTTY\plink.exe" -ssh -pw aPsswd %CMD_LINE_ARGS%
>>I'm using ant 1.6.2 (I also tried the version that comes with Eclipse
>>I found a lot of posts on this topic, however none of them answered my
>>Please let me know if you have a solution to this problem.

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message