ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject Re: method not found when running ant
Date Wed, 03 Nov 2004 20:16:17 GMT
It turns out there was a OS bundled version of ant. I removed it and my 
diagnostics test is correct now. My error is sourcejammer related now I 

this is the output from the diagnostics now and the attempted ant task.

[ballen@opacs184 sourcejammer]$ ant -diagnostics
------- Ant diagnostics report -------
Apache Ant version 1.6.2 compiled on July 16 2004

 Implementation Version (JDK1.2+ only)
core tasks     : 1.6.2
optional tasks : 1.6.2

 ANT_HOME/lib jar listing
ant.home: /usr/local/ant
ant-antlr.jar (5659 bytes)
ant-apache-bcel.jar (8609 bytes)
ant-apache-bsf.jar (12589 bytes)
ant-apache-log4j.jar (3014 bytes)
ant-apache-oro.jar (48015 bytes)
ant-apache-regexp.jar (3706 bytes)
ant-apache-resolver.jar (4073 bytes)
ant-commons-logging.jar (3856 bytes)
ant-commons-net.jar (35242 bytes)
ant-icontract.jar (9713 bytes)
ant-jai.jar (21351 bytes)
ant-javamail.jar (6753 bytes)
ant-jdepend.jar (8152 bytes)
ant-jmf.jar (6596 bytes)
ant-jsch.jar (22604 bytes)
ant-junit.jar (73665 bytes)
ant-launcher.jar (8673 bytes)
ant-netrexx.jar (9990 bytes)
ant-nodeps.jar (407573 bytes)
ant-starteam.jar (35463 bytes)
ant-stylebook.jar (2320 bytes)
ant-swing.jar (6755 bytes)
ant-trax.jar (68833 bytes)
ant-vaj.jar (48623 bytes)
ant-weblogic.jar (14355 bytes)
ant-xalan1.jar (4457 bytes)
ant-xslp.jar (2236 bytes)
ant.jar (999966 bytes)
xercesImpl.jar (1010675 bytes)
xml-apis.jar (124724 bytes)
commons-net.jar (1589 bytes)
sj_ant.jar (9527 bytes)
sj_client.jar (1235829 bytes)
soap.jar (232498 bytes)
activation.jar (54829 bytes)
sj_lib.jar (103029 bytes)
mail.jar (305434 bytes)

 Tasks availability
image : Missing dependency
sshexec : Missing dependency com.jcraft.jsch.UserInfo
scp : Missing dependency com.jcraft.jsch.UserInfo
cvsversion : Not Available
jdepend : Missing dependency jdepend.xmlui.JDepend
junit : Missing dependency junit.framework.Test

 org.apache.env.Which diagnostics
Not available.
Download it at

 XML Parser information
XML Parser : org.apache.xerces.jaxp.SAXParserImpl
XML Parser Location: /usr/local/ant/lib/xercesImpl.jar

 System properties
------------------------------------------- : Java(TM) 2 Runtime Environment, Standard Edition
sun.boot.library.path : /home/ballen/j2sdk1.4.2_06/jre/lib/i386
java.vm.version : 1.4.2_06-b03
ant.library.dir : /usr/local/ant/lib
java.vm.vendor : Sun Microsystems Inc.
java.vendor.url :
path.separator : : : Java HotSpot(TM) Client VM
file.encoding.pkg : : US
sun.os.patch.level : unknown : Java Virtual Machine Specification
user.dir : /usr/local/sourcejammer
java.runtime.version : 1.4.2_06-b03
java.awt.graphicsenv : sun.awt.X11GraphicsEnvironment
java.endorsed.dirs : /home/ballen/j2sdk1.4.2_06/jre/lib/endorsed
os.arch : i386 : /tmp
line.separator :

java.vm.specification.vendor : Sun Microsystems Inc. : Linux
ant.home : /usr/local/ant
sun.java2d.fontpath :
java.library.path : 
/home/ballen/j2sdk1.4.2_06/jre/lib/i386/client:/home/ballen/j2sdk1.4.2_06/jre/lib/i386:/home/ballen/j2sdk1.4.2_06/jre/../lib/i386 : Java Platform API Specification
java.class.version : 48.0
java.util.prefs.PreferencesFactory : 
os.version : 2.4.21-4.EL
user.home : /home/ballen
user.timezone : America/New_York
java.awt.printerjob : sun.print.PSPrinterJob
file.encoding : UTF-8
java.specification.version : 1.4
java.class.path : 
/usr/local/ant/lib/ant-launcher.jar:/java/jre/lib/jsse.jar:/usr/local/ant/lib/sj_ant.jar:/usr/local/ant/lib/sj_lib.jar:/usr/local/ant/lib/sj_client.jar:/usr/local/ant/lib/mail.jar:/usr/local/ant/lib/activation.jar:/usr/local/ant/lib/soap.jar:/usr/local/ant/lib/ant-antlr.jar:/usr/local/ant/lib/ant-apache-bcel.jar:/usr/local/ant/lib/ant-apache-bsf.jar:/usr/local/ant/lib/ant-apache-log4j.jar:/usr/local/ant/lib/ant-apache-oro.jar:/usr/local/ant/lib/ant-apache-regexp.jar:/usr/local/ant/lib/ant-apache-resolver.jar:/usr/local/ant/lib/ant-commons-logging.jar:/usr/local/ant/lib/ant-commons-net.jar:/usr/local/ant/lib/ant-icontract.jar:/usr/local/ant/lib/ant-jai.jar:/usr/local/ant/lib/ant-javamail.jar:/usr/local/ant/lib/ant-jdepend.jar:/usr/local/ant/lib/ant-jmf.jar:/usr/local/ant/lib/ant-jsch.jar:/usr/local/ant/lib/ant-junit.jar:/usr/local/ant/lib/ant-launcher.jar:/usr/local/ant/lib/ant-netrexx.jar:/usr/local/ant/lib/ant-nodeps.jar:/usr/local/ant/lib/ant-starteam.jar:/usr/local/ant/lib/ant-stylebook.jar:/usr/local/ant/lib/ant-swing.jar:/usr/local/ant/lib/ant-trax.jar:/usr/local/ant/lib/ant-vaj.jar:/usr/local/ant/lib/ant-weblogic.jar:/usr/local/ant/lib/ant-xalan1.jar:/usr/local/ant/lib/ant-xslp.jar:/usr/local/ant/lib/ant.jar:/usr/local/ant/lib/xercesImpl.jar:/usr/local/ant/lib/xml-apis.jar:/usr/local/ant/lib/commons-net.jar:/usr/local/ant/lib/sj_ant.jar:/usr/local/ant/lib/sj_client.jar:/usr/local/ant/lib/soap.jar:/usr/local/ant/lib/activation.jar:/usr/local/ant/lib/sj_lib.jar:/usr/local/ant/lib/mail.jar:/home/ballen/j2sdk1.4.2_06/lib/tools.jar : ballen
java.vm.specification.version : 1.0
java.home : /home/ballen/j2sdk1.4.2_06/jre : 32
user.language : en
java.specification.vendor : Sun Microsystems Inc. : mixed mode
java.version : 1.4.2_06
java.ext.dirs : /home/ballen/j2sdk1.4.2_06/jre/lib/ext
sun.boot.class.path : 
java.vendor : Sun Microsystems Inc.
file.separator : /
java.vendor.url.bug : : UnicodeLittle
sun.cpu.endian : little
sun.cpu.isalist :

[ballen@opacs184 sourcejammer]$ ant fetch
Buildfile: build.xml


[sjgetproject] SourceJammer archive (nas01)
[sjgetproject] SourceJammer server URL 
[sjgetproject] SourceJammer destination path (/home/ballen)
[sjgetproject] SourceJammer project path (/msrc/AEv2/src)
[sjgetproject] SourceJammer verify checkin (false)
[sjgetproject] SourceJammer make files read-only (false)
[sjgetproject] SourceJammer config path 
[sjgetproject] ac - /usr/local/sourcejammer/conf.xml
[sjgetproject] ac - /usr/local/sourcejammer/client/conf/conf.xml

java.lang.InternalError: Can't connect to X11 window server using ':0.0' 
as the value of the DISPLAY variable.

Total time: 1 second
[ballen@opacs184 sourcejammer]$ 
11/03/2004 02:51 PM
Please respond to
"Ant Users List" <>

"Ant Users List" <>

Re: method not found when running ant

I installed ant myself.

the version was 1.6.2 but when I run diagnostics, I get the following 
version output:
[ballen@opacs184 sourcejammer]$ ant -diagnostics
------- Ant diagnostics report -------
Apache Ant version 1.5.2-20 compiled on September 25 2003

[ballen@opacs184 sourcejammer]$ which ant
(by the way, this is a symbolic link to  /usr/local/apache-ant-1.6.2)

[ballen@opacs184 sourcejammer]$ $JAVA_HOME/bin/java -version
java version "1.4.2_06"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_06-b03)
Java HotSpot(TM) Client VM (build 1.4.2_06-b03, mixed mode)

when I run debug I get:

Apache Ant version 1.5.2-20 compiled on September 25 2003
Buildfile: build.xml
Detected Java version: 1.4 in: /usr
Detected OS: Linux
Could not load class 
( for task jjtree
Could not load class 
( for 
task jarlib-display
 +User datatype: dirset
 +User datatype: fileset
 +User datatype: filterreader
 +User datatype: filterset
 +User datatype: patternset
 +User datatype: regexp
 +User datatype: path
 +User datatype: selector
 +User datatype: mapper
 +User datatype: xmlcatalog
 +User datatype: description
 +User datatype: substitution
 +User datatype: filterchain
 +User datatype: filelist
Setting ro project property: ant.version -> Apache Ant version 1.5.2-20 
compiled on September 25 2003
Setting ro project property: ant.file -> /usr/local/sourcejammer/build.xml
parsing buildfile build.xml with URI = 
Setting ro project property: -> SourceJammer GetLabel Ant 

Adding reference: SourceJammer GetLabel Ant Task ->
Project base dir set to: /usr/local/sourcejammer
   +Task: property
Setting project property: /usr -> /java/bin
 +Target: init
   +Task: taskdef
 +Target: fetch

Target `main' does not exist in this project.
java.util.Hashtable, java.util.Hashtable, java.util.Stack, 
java.util.Vector) (/usr/lib/
java.util.Hashtable) (/usr/lib/
java.util.Properties, java.lang.ClassLoader) 

Total time: 0 seconds

Matt Benson <> 
11/03/2004 02:25 PM
Please respond to
"Ant Users List" <>

Ant Users List <>

Re: method not found when running ant

--- wrote:
> The only way I was able to get ant to stop
> complaining about those missing 
> classes was to place the fully qualified name
> (including the jar file 
> name) in the $CLASSPATH.

Then there is something abnormal going on, especially
given that the CLASSPATH you show includes jar files
that have been added to $ANT_HOME/lib .  This sounds
like the kind of nonsense we hear about when people
install Ant on Linux boxes that had Ant bundled as it
were with the OS.  Did you install Ant yourself?  What
version?  What output does "which ant" yield?  Are you
sure about your JAVA_HOME setting?  What does
"$JAVA_HOME/bin/java -version" yield?  What happens
when you run Ant with the --execdebug switch?


Do you Yahoo!? 
Check out the new Yahoo! Front Page. 

To unsubscribe, e-mail:
For additional commands, e-mail:

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message