ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject Re: method not found when running ant
Date Wed, 03 Nov 2004 19:51:21 GMT
I installed ant myself.

the version was 1.6.2 but when I run diagnostics, I get the following 
version output:
[ballen@opacs184 sourcejammer]$ ant -diagnostics
------- Ant diagnostics report -------
Apache Ant version 1.5.2-20 compiled on September 25 2003

[ballen@opacs184 sourcejammer]$ which ant
(by the way, this is a symbolic link to  /usr/local/apache-ant-1.6.2)

[ballen@opacs184 sourcejammer]$ $JAVA_HOME/bin/java -version
java version "1.4.2_06"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_06-b03)
Java HotSpot(TM) Client VM (build 1.4.2_06-b03, mixed mode)

when I run debug I get:

Apache Ant version 1.5.2-20 compiled on September 25 2003
Buildfile: build.xml
Detected Java version: 1.4 in: /usr
Detected OS: Linux
Could not load class 
( for task jjtree
Could not load class 
( for 
task jarlib-display
 +User datatype: dirset
 +User datatype: fileset
 +User datatype: filterreader
 +User datatype: filterset
 +User datatype: patternset
 +User datatype: regexp
 +User datatype: path
 +User datatype: selector
 +User datatype: mapper
 +User datatype: xmlcatalog
 +User datatype: description
 +User datatype: substitution
 +User datatype: filterchain
 +User datatype: filelist
Setting ro project property: ant.version -> Apache Ant version 1.5.2-20 
compiled on September 25 2003
Setting ro project property: ant.file -> /usr/local/sourcejammer/build.xml
parsing buildfile build.xml with URI = 
Setting ro project property: -> SourceJammer GetLabel Ant 
Adding reference: SourceJammer GetLabel Ant Task ->
Project base dir set to: /usr/local/sourcejammer
   +Task: property
Setting project property: /usr -> /java/bin
 +Target: init
   +Task: taskdef
 +Target: fetch

Target `main' does not exist in this project.
java.util.Hashtable, java.util.Hashtable, java.util.Stack, 
java.util.Vector) (/usr/lib/
java.util.Hashtable) (/usr/lib/
java.util.Properties, java.lang.ClassLoader) 

Total time: 0 seconds

Matt Benson <> 
11/03/2004 02:25 PM
Please respond to
"Ant Users List" <>

Ant Users List <>

Re: method not found when running ant

--- wrote:
> The only way I was able to get ant to stop
> complaining about those missing 
> classes was to place the fully qualified name
> (including the jar file 
> name) in the $CLASSPATH.

Then there is something abnormal going on, especially
given that the CLASSPATH you show includes jar files
that have been added to $ANT_HOME/lib .  This sounds
like the kind of nonsense we hear about when people
install Ant on Linux boxes that had Ant bundled as it
were with the OS.  Did you install Ant yourself?  What
version?  What output does "which ant" yield?  Are you
sure about your JAVA_HOME setting?  What does
"$JAVA_HOME/bin/java -version" yield?  What happens
when you run Ant with the --execdebug switch?


Do you Yahoo!? 
Check out the new Yahoo! Front Page. 

To unsubscribe, e-mail:
For additional commands, e-mail:

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message