ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabricio M. Sanchez" <>
Subject SOLVED: ZipException on javac task moving from jdk1.4 to jdk1.5
Date Wed, 08 Jun 2005 08:51:49 GMT
Thank you very much, problem is solved!

Maurice, my JAVA_HOME was set to the correct jdk 1.5.0_03 that was being
used by my javac task (I unistalled jdk 1.4.2 to be sure!), thanks for that!

Stefan and Peter, bingo! I did have generated .class files on my

I followed Peter's advice and removed any references to .class files that
were being generated from my classpath reference
"compile-classpath". This stopped the ZipExceptions appearing, and it builds
successfully again!!!

Although, this doesn't explain why the error did not occurr (with both ant
1.6.1 and 1.6.5) while I was using jdk1.4.2. The error happened only when I
moved to jdk 1.5.0_03....? Maybe it has come back from jdk1.3 as Stefan

Thanks again!


-----Original Message-----
From: Peter Reilly [] 
Sent: 07 June 2005 22:48
To: Ant Users List
Subject: Re: ZipException on javac task moving from jdk1.4 to jdk1.5

This should be a FAQ!

You have a .class file in your class path (i.e. not a directory or a .jar
file). Starting with ant 1.6, ant will open the files in the classpath
checking for manifest entries. This attempted opening will fail with the
error ""

The problem does not exist with ant 1.5 as it does not try to open the
files. - so make sure that your classpath's do not contain .class files.


Fabricio M. Sanchez wrote:

>Hi there,
>I've searched google, ant-faq and ant-manual and found nothing 
>I have recently moved from java (jdk) 1.4.2 to 1.5.0_03.
>I'm using ant 1.6.1 (I've tried ant 1.6.5 also, but the problem still
>After deleting all classes and compiling using the javac task (target 
>name is compile, see code below), I then compile the source again. The 
>first time I compile (using 'ant compile')it builds successfully. When 
>I compile again (without modifying any files) and only on jdk1.5.0_03 
>(it works fine on jdk1.4.2) I get the
>Has this happened to anyone? Any ideas on what to do to resolve it?
>Thank you for your time,
>Code below....
>---- Start of build.xml compile target ----
><!-- Compiles Application -->
>  <target name="compile">
>    <javac srcdir="${home}/${src}" destdir="${home}/${classes}"
>           classpathref="compile-classpath"
>           debug="on" optimize="off" deprecation="on"/>          <-- line
>105 on build.xml (see output, below)
>  </target>
>---- End of build.xml compile target ----
>---- Start of Ant Output ----
>C:\current_with_version>ant compile
>Buildfile: build.xml
>    [javac] Compiling 13 source files to C:\current_with_version\classes
>    [javac] error: error reading 
>C:\current_with_version\classes\com\esp\cost\CostElement.class; jav
> error in opening zip file
>    [javac] Note: Some input files use unchecked or unsafe operations.
>    [javac] Note: Recompile with -Xlint:unchecked for details.
>    [javac] 1 error
>C:\current_with_version\build.xml:105: Compile failed; see the compiler 
>error output for details.
>Total time: 48 seconds
>---- End of Ant Output ----

To unsubscribe, e-mail:
For additional commands, e-mail:

No virus found in this incoming message.
Checked by AVG Anti-Virus.
Version: 7.0.323 / Virus Database: 267.6.4 - Release Date: 06/06/2005

No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.323 / Virus Database: 267.6.5 - Release Date: 07/06/2005

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message