ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frank W. Zammetti" <>
Subject Weird error with Jar task
Date Tue, 21 Jun 2005 18:58:37 GMT
Hi all... I have a strange situation with a JAR task... I'm dealing with 
a build script that has always worked and has not changed.  The version 
of Ant has not changed (1.6.1) and in fact nothing else that I can 
identify has changed.

The error I get is:

C:\tomcat\webapps\ajaxtags\WEB-INF\src\build.xml:224: Unable to rename 
old file (C:\tomcat\webapps\ajaxtags\WEB-INF\src\struts.jar) to 
temporary file

Here is the task and the three relevant properties:

<property name="src" value="./" />
<property name="classes" value="../classes" />
<property name="webinf" value="../" />
<target name="update_jar">
   <echo message="Updating JAR..." />
   <jar destfile="${src}/struts.jar" basedir="${classes}" update="true" 
excludes="com/**/*" />
   <jar destfile="${src}/struts.jar" basedir="${src}/META-INF" 
update="true" includes="struts-html.tld" />
   <copy file="${src}/META-INF/tlds/struts-html.tld" todir="${webinf}" 
overwrite="true" />
   <copy file="${src}/struts.jar" todir="${libs}" overwrite="true" />
   <delete dir="${classes}/org" />
   <delete dir="${src}/META-INF" />
   <echo message="Done" />

This is from within a src directory under WEB-INF of a webapp.  Like I 
said, this has always worked before, it just suddenly stopped today.

The only reference I found on the web was to this:

...where the Log4J crew seems to experience this sporadically.  Problem 
is, I have rebooted, re-checked out the project from CVS and tried to 
build probably 30 times now, and it keeps happening.

Any pointers?  Thanks!

Frank W. Zammetti
Founder and Chief Software Architect
Omnytex Technologies

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message