ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frank W. Zammetti" <fzli...@omnytex.com>
Subject JAR task problem
Date Tue, 21 Jun 2005 20:16:22 GMT
Argh, today seems to be the day of "things that worked 10 minutes ago 
don't now"...

I have a JAR task...

<jar destfile="${src}/struts.jar" basedir="${src}" update="true" 
includes="META-INF/*" />

Under the directory ${src} points to I have a META-INF directory with a 
tlds directory in it, in which are two .tld files.  The TLDs are already 
in the JAR, so I'm just trying to update them.

I have verified that the .tld files are the versions I want updated in 
the JAR.  But, when I executed this, no error occurs, no message saying 
anything went wrong, but the JAR is not updated.  I've tried a number of 
different variations of the above, including setting the basedir to 
${src}/META-INF, trying various wildcards in the includes clause, 
explicitly naming the two .tld files, using a <fileset> underneath, etc. 
  Nothing has worked.

I'll just be over here in the corner banging my head against the wall, 
if anyone would like to tap me on the shoulder with a suggestion, I'd 
appreciate it :)

-- 
Frank W. Zammetti
Founder and Chief Software Architect
Omnytex Technologies
http://www.omnytex.com


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message