ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rhino" <rhi...@sympatico.ca>
Subject Re: Question re sshexec task
Date Mon, 19 Dec 2005 20:16:16 GMT
I'm not sure. I'll check with the system administrator and get back to 
you....

Rhino

----- Original Message ----- 
From: "Anderson, Rob (Global Trade)" <Rob.Anderson@nike.com>
To: "Ant Users List" <user@ant.apache.org>
Sent: Monday, December 19, 2005 2:11 PM
Subject: RE: Question re sshexec task


It may be that your ssh keyfile is in the wrong format. What
version/vendor of ssh did you use to generate the keyfile?

-Rob Anderson

> -----Original Message-----
> From: Rhino [mailto:rhino1@sympatico.ca]
> Sent: Saturday, December 17, 2005 3:31 PM
> To: ant-user
> Subject: Question re sshexec task
>
> Is there any problem with blanks or apostrophes within the
> name of a keyfile in an sshexec task? I am running Ant 1.6.5
> in Eclipse 3.1.1.
>
> Our environment changed recently so I need to modify my build
> scripts to use keys instead of passwords. After reading the
> sshexec article in the Ant manual, I wrote the following
> trivial task to display the current directory on our Linux server:
>
> <sshexec host="www.bongo.ca" username="rhino"
> keyfile="C:\Documents and Settings\Rodeo\Desktop\Bob's
> Server\Rodeos key.ppk"
>
> passphrase="snarfle" trust="true"
>
> command="pwd"/>
>
>
> When I executed this task, this is what I found in the output:
>
> [sshexec] Identity: com.jcraft.jsch.JSchException: invaid privatekey:
> C:\Documents and Settings\Rodeo\Desktop\Bob's Server\Rodeos key.ppk
>
> BUILD FAILED
>
> E:\eclipse\3.1.1\eclipse\workspace\Resume_JDK_1.5.0\xml\tonge.
> xml:106:
> com.jcraft.jsch.JSchException: invaid privatekey:
> C:\Documents and Settings\Rodeo\Desktop\Bob's Server\Rodeos key.ppk
>
> Although the message seems to be complaining about my private
> key, the message contains the path to the key file. The path
> to the key file is correct so I'm guessing that the sshexec
> task has a problem with embedded blanks or apostrophes in the path.
>
> Can anyone confirm that or suggest an alternate explanation?
> I'd like to get this task working again.
>
> Also, just a little thing but how do I notify the developer
> of this task about the typo in the error message; he/she's
> got "invalid" spelled without the 'l'. This is an optional
> task so I'm not sure if I have to contact them directly or if
> I can get a message to them via this mailing list.
>
>
> Rhino
>
>
>
> --
> No virus found in this outgoing message.
> Checked by AVG Free Edition.
> Version: 7.1.371 / Virus Database: 267.14.1/206 - Release
> Date: 16/12/2005
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


-- 
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.1.371 / Virus Database: 267.14.1/206 - Release Date: 16/12/2005




-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.371 / Virus Database: 267.14.1/206 - Release Date: 16/12/2005


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message