ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick De Mazière <>
Subject install, list, reload and remove suddenly die
Date Thu, 01 Dec 2005 13:08:22 GMT

I got recently a very mysterious problem when using ant. Projects I was 
able to compile, install etc. in the past, now no longer want to be 
installed, reloaded, listed or removed, and it all happened after a 
restart of my tomcat server (I did not change any config file of that 
server in between). I was using ant on the command line for one of the 
projects using the next command: ant -v -d remove. This is the output I got:

Apache Ant version 1.6.2 compiled on November 30 2005
Buildfile: build.xml
Adding reference: ant.PropertyHelper
Detected Java version: 1.4 in: /opt/sun-jdk-
Detected OS: Linux
Adding reference: ant.ComponentHelper
Setting ro project property: ant.version -> Apache Ant version 1.6.2 
compiled on November 30 2005
Setting ro project property: ant.file -> /home/wheetle/rs_test/build.xml
Adding reference: ant.projectHelper
Adding reference: ant.parsing.context
Adding reference: ant.targets
parsing buildfile /home/wheetle/rs_test/build.xml with URI = 

Adding reference: class.path
Class org.apache.catalina.ant.DeployTask loaded from parent loader 
 +Datatype deploy org.apache.catalina.ant.DeployTask
Class org.apache.catalina.ant.ListTask loaded from parent loader 
 +Datatype list org.apache.catalina.ant.ListTask
Class org.apache.catalina.ant.ReloadTask loaded from parent loader 
 +Datatype reload org.apache.catalina.ant.ReloadTask
Class org.apache.catalina.ant.UndeployTask loaded from parent loader 
 +Datatype undeploy org.apache.catalina.ant.UndeployTask
Build sequence for target `remove' is [remove]
Complete build sequence is [remove, prepare, compile, reload, 
create_war, install, deploy, list, javadoc, ]


and then he stops reacting .... I got to press Ctrl-C
When I run a top on my machine, I see all JVM turn idle (0% CPU) when 
ant reaches the aforementioned state. Identical things can be spotted 
when I run an ant install, ant reload, or ant list. The commands ant 
deploy, prepare, compile, create_war, and javadoc are succesful. I tried 
it also with other projects but got always the same strange behaviour ....

Anyone encountered already such behaviour, and if so, knowns what to do 
about it ?
Any help would be greatly appreciated !

Many thanks in advance,

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message