ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brown, Carlton" <>
Subject Cross-platform portability problem for copy/filterset
Date Thu, 01 Dec 2005 19:47:02 GMT


A build file that I had developed under Windows started throwing a
strange error when I tried to run it on a Linux box.   The error is
"failed to copy due to null" (not terribly informative).   Has anyone
seen this before?  I saw the question asked on usenet before but no
answer was given.


Here is the error:



The following error occurred while executing this line:

:69: Failed to copy
/home/zmsyggs/dev/jbbos/r18.6/src/jbbos/nimbus/config/properties.src to
/home/zmsyggs/dev/jbbos/r18.6/build/jbbos/nimbus/config/properties due
to null


Null what?  It would be nice to know.   


Anyway, here is the fragment that causes the problem:


                <copy todir="${nimbus.config.dir}"  verbose="true"

                        <fileset dir="${nimbus.src.root}/config">



                        <mapper type="glob" from="*.src" to="*" />

                        <filterset begintoken="@#$%" endtoken="%$#@">





If I comment out the filterset, the error does not occur.

If I run the build file on Windows, the error does not occur.


Anybody have any ideas?





  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message