ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Teasel <>
Subject Re: help! taskdef cannot be found
Date Sun, 04 Feb 2007 23:28:59 GMT

Anil Philip wrote:
> I am trying to run the Quartz webapp from Sun Java
> Studio 8.1 using Tomcat. I am using the ant scripts
> that come with Quartz webapp.
> When I try to Run (in Sun Studio 8.1), I get
> "taskdef
> cannot be found"
> the build.xml for webapp is here:
> Any help appreciated.
> thanks,
> Anil

I'm getting the same error trying to compile my first servlet under

$ ant
Buildfile: build.xml
/var/lib/tomcat5/webapps/test1/WEB-INF/build.xml:147: taskdef class
org.apache.catalina.ant.DeployTask cannot be found
Total time: 0 seconds

I have copied catalina-ant.jar into /usr/share/ant/lib, as instructed
I have tried jar tvf /usr/share/ant/lib/catalina-ant.jar, and the classes
are definitely there
I have tried ant -lib /usr/share/ant/lib
I have tried exporting ANT_HOME myself, rather than relying on /etc/ant.conf
I have tried banging my fist on the desk

...but nothing seems to work.  If anyone has any suggestions, or pointers to
documentation that doesn't just say "copy in the catalina-ant.jar file and
all will be well, they'd be much appreciated!


View this message in context:
Sent from the Ant - Users mailing list archive at

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message