ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <>
Subject AW: using * in arg of exec task
Date Mon, 12 Feb 2007 11:27:29 GMT
You're running into the illusion that the * is resolved by the operating system.
It is resolved by the shell (cmd, command, csh, ...). 

Does your script want to get a '*' as argument (Class*.class) and it does processing
for its own? Then just use the Ant implementation you have.

But if you need wildcard expansion (ClassOne.class ClassTwo.class) you have to do that
for you own in Ant: <fileset> <pathconvert>


>-----Urspr√ľngliche Nachricht-----
>Von: Martin M [] 
>Gesendet: Montag, 12. Februar 2007 11:08
>Betreff: using * in arg of exec task
>Hi all,
>I would like to call a helper script in my ant-task, but 
>somehow I dont't
>get it running.
>I would like to call
>"myCript /path/to/classes/Class*.class
>I have defined this exec task:
><exec executable="myCrypt" dir=".">
><arg line="path/to/classes/Class*.class
>Running the task, ant is complaining that the classes don't exist. 
>I also tried to escape the '*' by \, $, and *, but nothing worked.
>How do I define such a task in ant?
>Thanks in advance!
>View this message in context: 
>Sent from the Ant - Users mailing list archive at
>To unsubscribe, e-mail:
>For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message