ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Jackson" <>
Subject Re: Strange property problem
Date Tue, 05 Jun 2007 02:03:30 GMT
Hi all,

This problem was actually to do with the names of the tar file and
what the folders were in named inside the tar file - it was not to do
with the macro property expansion (which I also thought was the

basically the tar was called james-server-binary-next-major (james
distro built from the current james trunk), but inside this the
folders were called james-server-next-major.

So when I scp'd the file to the server with james.version =
james-server-binary-next-major, the scp command worked, and the tar
command worked, but the output from the tar command produced
james-server-next-major - this looked like incorrect output, and later
on in the build there was a failure because the a symbolic link wasn't
pointing to the expanded tar it was pointing to a non-existent

Simple fix was to rename the tar I was uploading to
james-server-next-major (same name as the folder inside the tar) and
change the property to james-server-next-major and everything worked
fine.  Took 2 days to sort out though.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message