ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Martin" <>
Subject RE: Problem installing regexp option
Date Thu, 05 Mar 2009 09:53:16 GMT
Solved my own problem.  I installed the RPM package ant-nodeps

	yum install ant-nodeps

As it turns out it does in fact install into the /usr/share/java/ant
directory instead of /usr/share/ant/lib directory as one would expect.

-----Original Message-----
I have an Openbravo build process that uses regexp.  We have installed
Ant 1.7.1 and it is running on CentOS 5.  We had to install from
JPackage in order to get the latest Ant release.  The problem that we
are running into is that the script gets the following exception when


/tmp/build.xml:4: No supported regular expression matcher found:


I found that I needed the ant-contrib package but jpackage doesn't have
a current version that supports 1.7.x so I tried to chase down the
specific jar.  What I found was that it requires the
ant-nodeps-1.7.1.jar which I was able to find and download.  I confirmed
that the class in question is in the jar:


unzip -l /usr/share/ant/lib/ant-nodeps-1.7.1.jar  | grep

     2673  06-27-08 05:03


I tried placing the jar into the $ANT_HOME/lib directory and have done
the 'ant -diagnostics' which now shows the jar in the class path:


ant -diagnostics | grep class.path


java.class.path :

sun.boot.class.path :


ant.library.dir : /usr/share/ant/lib


I read where ant "lies" about jars in
and tried moving the jar to the /usr/share/java and /usr/share/java/ant
directories but got the same results.  I also tried the -lib switch when
running ant.  None of these steps worked.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message