ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damjan Perenic <>
Subject Re: Does mail task work on Eclipse on Mac OSX 10.6?
Date Fri, 11 Sep 2009 11:59:58 GMT
On Fri, Sep 11, 2009 at 9:30 AM, Chris Kimball <> wrote:
> At this point, I've done the following:
> 1. Installed Eclipse 3.5.  It does have ant 1.7.1, an improvement.
> 2. Inserted the jars activation.jar (jaf-1.0.2) mail, smtp, and pop
> (javamail-1.42.) as Global Entries under the Preferences ant Runtime window.
> 3. Stopped using the Run as ... External tools configuration entirely.
> and I'm getting the familiar
> java.lang.NoClassDefFoundError: com/sun/mail/util/LineInputStream
> even though it's clearly in mail.jar of javamail-1.4.2 .
> My other ant scripts run correctly.
> My guess is that it's a MacOSX problem.  Possibly 32 vs 64 bit stuff.

I haven't tried Mac OS X 10.6 yet, but this is an issue also under
Leopard. Built-in ant does not load optional libraries at all. It does
not matter where you put them. I reported this issue to Apple with
testcases one year ago (rdar 6239066), but it hasn't been solved yet
and is still present on Leopard.
In my ~/.ant I have libraries for SSH an perforce. With built-in ant I
am not able to run any task requiring optional libraries.

My workaround on Leopard is:
I unpacked ant distribution 1.7.1 somewhere on my home. I set
environment variable ANT_HOME pointing to that directory and it works.
It finds all optional libraries.

Kind regards,
Damjan Perenic

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message