ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Dekker <>
Subject Problem with Undeploy Task in Tomcat 6
Date Mon, 14 Dec 2009 05:58:17 GMT
Hello there,

I am using Tomcat 6, Apache Ant 1.7.1 and JDK 1.6 on OS X Snow Leopard...

Am able to deploy my war into tomcat (via my Ant build script's deploy
target), but not with my undeploy target.

Excerpts from build.xml:

<target name="deploy" depends="compile">
    <jar jarfile="${build.dir}/${}.war"
basedir="${}" />
    <!-- Copy the newly built WAR file into the deployment directory -->
    <copy file="${build.dir}/${}.war"
todir="${tomcat.deployment.dir}" />

<target name="clean" description="Clears all generated files,
including build directories, distributables, and documentation.">
    <delete dir="${build.dir}"/>
<target name="undeploy" depends="clean" description="Remove
application in Tomcat">
    <undeploy url="${tomcat.manager.url}"

When I run the deploy target, everything works (it places
myproject.war) underneath $CATALINA_HOME/webapps...

However, when I run the undeploy target, I get the following error message:

Buildfile: /Users/myuser/work/myproject/build.xml
Trying to override old definition of datatype resources
   [delete] Deleting directory /Users/myuser/work/myproject/build

/Users/myuser/work/myproject/build.xml:83: Server
returned HTTP response code: 403 for URL:

Total time: 170 milliseconds

For a full description (containing the build.xml,,,, and tomcat-users.xml code
listings), please see this (I posted this to an online forum):

Would really appreciate it if someone could help me.

Happy programming,


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message