ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Larsen <>
Subject Re: taskdef A class needed by class X cannot be found: Task
Date Mon, 11 Jul 2011 08:55:02 GMT

Hash: SHA1

Hi Dominique, thanks for the reply.

On 2011-07-08 15:40, Dominique Devienne wrote:
> I'm no expert, but have you tried -noclasspath and/or -nouserlib
> described here: ?
Just did but without any luck.
The -nouserlib won't work since my own task is in a jar in
$HOME/.ant/lib but I also tried moving all jars except this one out of
the library dir. Still without any luck.
> Depending how you got Ant installed, manually by downloading and
> expanding it yourself, or by using an OS-specific package manager,
> there had been reports in the past of problems with the way the
> various "packaged" Ants behaved compared to the "official" Ant. If
> you've used a packaged Ant, try using the official one instead,
> combined with -noclasspath at least.
I tried with a newly downloaded Ant and JDK:
$ ant -version && java -version && javac -version
Apache Ant(TM) version 1.8.2 compiled on December 20 2010
java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)
javac 1.6.0_26

...but that didn't work either :-(

So, it is not Java, not Ant, not my own jar file (since it works on
another machine). Something in my setup must be at fault, but my
CLASSPATH environment variable is unset, $HOME/.java is deleted, and I
have verified with 'strace' that all the same jar files are loaded on
both the machine that works and the machine that doesn't.

Any other suggestions ?
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla -


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message