ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dominique Devienne <>
Subject Re: taskdef A class needed by class X cannot be found: Task
Date Fri, 08 Jul 2011 13:40:27 GMT
On Fri, Jul 8, 2011 at 7:02 AM, Robert Larsen <> wrote:
> I am having a problem with an Ant installation on my Ubuntu 11.04.
> I have a task which I have made myself and it has always worked (and
> actually still does) but now I am getting the below error: [...]
> Any ideas what I should do next ?
> I feel like I have tried everything.

I'm no expert, but have you tried -noclasspath and/or -nouserlib
described here: ?

Depending how you got Ant installed, manually by downloading and
expanding it yourself, or by using an OS-specific package manager,
there had been reports in the past of problems with the way the
various "packaged" Ants behaved compared to the "official" Ant. If
you've used a packaged Ant, try using the official one instead,
combined with -noclasspath at least.

Good luck. --DD

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message