ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bart van der Schoor <>
Subject Beginner question: Ant+ Eclipse + script-task: BSF's & Rhino E4X issue
Date Thu, 21 Jul 2011 09:02:57 GMT

I'm new to Ant and advanced usage of Eclipse, and I got terribly lost while
trying to solve the following. Worst of all i have no idea where to turn to
solve this so i hope somebody here can help more of point me in the right
direction (so many projects).

I have an Ant script-task using javascript where I want to parse XML using
E4X.  If I check the Ant project page I see it uses BSF which in turn uses
Rhino. But the E4X doesn't work: it seems like the Rhino it's using doesn't
have it supported. But when i browse Rhino's release I see it in 1.6, which
dates to 2004 (

The i tried to find out which version of Rhino is being used by the Ant
that's in my Eclipse, and tthen it all goes foggy. I tried googling and
browsing the different projects, but it's so confusing. I also tried
browsing release notes, but i have no idea which project to look in.

Can anyone give me some pointers on this?

I'm using Ant 1.8.2 in FDT, which is a standalone version of an ActionScript
plugin for Eclipse. It's FDT 4.5, which runs on Eclipse 3.5.0. It originally
shipped with Ant 1.7.1, but when solving an issue with the FTP task the
support guys send me an updated Ant 1.8.2 and the additional jar's
(commons-net and jakarta-oro). My workstation is an Windows XP machine, and
is using Sun jdk1.6.0_21.



  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message