ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Black <>
Subject Re: ant task ftp
Date Fri, 11 Jan 2013 06:59:57 GMT

When I run it with the new version commons-net-3.2, there is no error. But even if there is
a file on the ftp server, it was not downloaded. The process completed without raising error.
I even tried to run with debug and compare the two versions. The only difference is that with
the old version, the file was downloaded.

I will put the commons-net-3.x.jar in the ant/lib directory. Just by swapping the 3.1 and
3.2 version, the result is different.

Thanks for the advice, but I think I am not good enough to dig the source codes. However,
I will try more to see what I can find out.

with best regards,

 From: Antoine Levy Lambert <>
To: Ant Users List <>; Joe Black <> 
Sent: Thursday, January 10, 2013 11:00 AM
Subject: Re: ant task ftp
Hello Joe,

this looks like a bug or incompatibility between ant and this new version of commons-net.

It would be good if you can create a bug report in bugzilla (

What would be great is if you could start digging in the source code of ant and commons-net
to understand why the ftp does not work with commons-3.2.jar.

Does the build hang ? Is there an extra dependency which is missing ? 

Patches are welcome :-)


On Dec 26, 2012, at 12:38 AM, Joe Black wrote:

> Hi,
> I am using ant to download the files from the server
> using FTP.
> Previously, I am using ant-1.8.4 together with
> commons-net-3.1.jar as follows:
> <target name=”ftp”>
> <ftp server=”serverName” userid=”xxx” password=”xxx”
> action=”get”
>   Remotedir=”/home/dir”
> newer=”true” timediffauto=”true”>
>   <fileset
> dir=”../data”>
>     <include
> name=”${file}*”/>
>   </fileset>
> </ftp>
> It was running fine.
> However, recently I changed the (commons-net.3.1.jar)
> with (commons-3.2.jar). 
> The above program did not work anymore.
> When I changed back to 3.1 version, it is still working.
> Any ideas?
> thanks and best regards,
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message