apr-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 62640] libtool invocations should use --tag=CC
Date Thu, 30 Aug 2018 19:17:41 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=62640

--- Comment #4 from Michael Osipov <1983-01-06@gmx.net> ---
(In reply to Rainer Jung from comment #3)
> As far as I remember from having similar troubls long ago, the libtool
> script runs into the "unable to infer tagged configuration" error, when you
> compile with compiler or CC which is not a leading substring of what is set
> as "CC" (or "LTCC"?) in the libtool script itself.
> 
> So in some sense libtool, when created, records compiler info and refuses to
> compile if you change the compiler later in an incompatible way (adding
> flags at the end of CC would be compatible).
> 
> What I do not know, if custom CC will overwrite libtool builtin CC when you
> add the --tag flag.
> 
> To get the piture clear, we would need to know, what the definition of CC
> and LTCC is in the various libtool scripts involved (platform one, APR one),
> what CC was used to compile APR and what CC should be used to compile the
> artefact that fails compilation.

This is actually the issue I am expriencing on HP-UX with aCC.

The libtool generated differs from the libtool on my system. Especially
'available_tags' are empty.

LTCC is not set by me, but CC=/opt/aCC/bin/aCC. The CC assumed at time of
packaging libapr is a different one used by me and this does not work.

I can provide the output of the failures on Monday as soon as I get access to
the HP-UX servers at work.

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@apr.apache.org
For additional commands, e-mail: bugs-help@apr.apache.org


Mime
View raw message