aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Nodet <gno...@gmail.com>
Subject Re: Build failure since the pom update
Date Tue, 21 Dec 2010 17:24:44 GMT
I doubt, has the only change it a grep replace 0.3-incubating-SNAPSHOT
to 0.3-SNAPSHOT.
In addition it works with maven 3 but fails with 2.2 (both offline).
I'm sure the same error would happen if I revert the change, clean my
repo from any snapshot and build offline.
Since I've uploaded a snapshot, I suspect you won't see the problem
again, even with maven 2, but it looks like a maven problem.   I think
it comes from the fact that we use the *bundle* packaging but depend
on the jar (from a maven dependency pov).

On Tue, Dec 21, 2010 at 17:48, Mark Nuttall <mnuttall@apache.org> wrote:
> Guillaume,
> Please see https://hudson.apache.org/hudson/job/Aries/805/  - it does
> seem very likely that your changes are responsible for the broken
> build.
>
> Regards,
> Mark
>
> On 21 December 2010 16:41, Guillaume Nodet <gnodet@gmail.com> wrote:
>> It was working for me when building from the upper level (at least once).
>>
>> On Tue, Dec 21, 2010 at 17:38, Alasdair Nottingham <not@apache.org> wrote:
>>> Hi,
>>>
>>> Our builds are failing since the pom's have been updated. I suspect
>>> this relates to the snapshot repo, but that is a guess on my part,
>>> does anyone know?
>>>
>>> Alasdair
>>>
>>> --
>>> Alasdair Nottingham
>>> not@apache.org
>>>
>>
>>
>>
>> --
>> Cheers,
>> Guillaume Nodet
>> ------------------------
>> Blog: http://gnodet.blogspot.com/
>> ------------------------
>> Open Source SOA
>> http://fusesource.com
>>
>



-- 
Cheers,
Guillaume Nodet
------------------------
Blog: http://gnodet.blogspot.com/
------------------------
Open Source SOA
http://fusesource.com

Mime
View raw message