aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Ward <timothyjw...@apache.org>
Subject RE: Aries integration tests and OSGi 4.3
Date Wed, 26 Oct 2011 14:51:12 GMT

Hi David,

Merging into trunk should be fine, JMX hasn't been staged yet so it shouldn't affect anything
in the current release run. If you do it quickly it might even make it in to the next set
of releases that Jeremy and I will be preparing for JPA :).

Regards,

Tim

> From: david.bosschaert@gmail.com
> Date: Wed, 26 Oct 2011 13:40:00 +0100
> Subject: Re: Aries integration tests and OSGi 4.3
> To: dev@aries.apache.org
> 
> Hi Timothy,
> 
> Thanks for the pointer. I managed to get that to work.
> I'd like to merge this update to jmx-itests, just making sure - Aries
> trunk is open, right? (I'm a little out of the loop wrt to the release
> that I think is currently being prepared).
> 
> Cheers,
> 
> David
> 
> On 17 October 2011 11:32, Timothy Ward <timothyjward@apache.org> wrote:
> >
> > Hi David,
> >
> > It's definitely possible, we do this in the Proxy component, the JPA component,
the EJB component, and probably some other places. We have our own platform definition for
the OSGi core 4.3 RI (an equinox build from June) in each project. It should be easy to copy
across and to extend it to cover Felix as well. What would be really nice would be to use
a version of pax-exam that had them supported by default, but I don't know if that exists.
> >
> > Regards,
> >
> > Tim
> >
> >> From: david.bosschaert@gmail.com
> >> Date: Mon, 17 Oct 2011 10:14:40 +0100
> >> Subject: Aries integration tests and OSGi 4.3
> >> To: aries-dev@incubator.apache.org
> >>
> >> Hi all,
> >>
> >> I'm working on upgrading the Aries JMX implementation to be compliant
> >> with RFC 169 [1] and in the process of that was intending to run the
> >> pax-exam based integration tests under an OSGi 4.3 compliant
> >> framework. Currently we're on Pax-Exam 1.2.3 in Aries. Has anyone been
> >> able to run a 4.3 compliant framework (such as Eclipse 3.7 or Felix
> >> 4.0.0) with that?
> >>
> >> Thanks,
> >>
> >> David
> >>
> >> [1] http://www.osgi.org/download/osgi-early-draft-2011-09.pdf
> >
 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message