aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alasdair Nottingham <...@apache.org>
Subject Problem building aries
Date Fri, 14 Oct 2011 15:05:19 GMT
Hi,

I've just done an svn up and nothing will build. I get the following
exception:

[INFO] Scanning for projects...
[ERROR] The build could not read 4 projects -> [Help 1]
[ERROR]
[ERROR]   The project
org.apache.aries.application:org.apache.aries.application.api:0.3.1-SNAPSHOT
(/Users/nottinga/Documents/apache/aries/trunk/application/application-api/pom.xml)
has 1 error
[ERROR]     Non-resolvable parent POM: Could not find artifact
org.apache.aries:java5-parent:pom:0.5-SNAPSHOT and 'parent.relativePath'
points at wrong local POM @ line 21, column 13 -> [Help 2]
[ERROR]
[ERROR]   The project
org.apache.aries.application:org.apache.aries.application.utils:0.3.1-SNAPSHOT
(/Users/nottinga/Documents/apache/aries/trunk/application/application-utils/pom.xml)
has 1 error
[ERROR]     Non-resolvable parent POM: Could not find artifact
org.apache.aries:java5-parent:pom:0.5-SNAPSHOT and 'parent.relativePath'
points at no local POM @ line 21, column 13 -> [Help 2]
[ERROR]
[ERROR]   The project
org.apache.aries.application:org.apache.aries.application.modeller:0.3.1-SNAPSHOT
(/Users/nottinga/Documents/apache/aries/trunk/application/application-modeller/pom.xml)
has 1 error
[ERROR]     Non-resolvable parent POM: Could not find artifact
org.apache.aries:java5-parent:pom:0.5-SNAPSHOT and 'parent.relativePath'
points at no local POM @ line 21, column 13 -> [Help 2]
[ERROR]
[ERROR]   The project
org.apache.aries.application:application-modeller-standalone:0.3.1-SNAPSHOT
(/Users/nottinga/Documents/apache/aries/trunk/application/application-modeller-standalone/pom.xml)
has 1 error
[ERROR]     Non-resolvable parent POM: Could not find artifact
org.apache.aries:java5-parent:pom:0.5-SNAPSHOT and 'parent.relativePath'
points at no local POM @ line 21, column 13 -> [Help 2]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e
switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please
read the following articles:
[ERROR] [Help 1]
http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
[ERROR] [Help 2]
http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException

does anyone know what the problem might be?

maven -version shows this:

Apache Maven 3.0.3 (r1075438; 2011-02-28 17:31:09+0000)
Maven home: /usr/share/maven
Java version: 1.6.0_26, vendor: Apple Inc.
Java home: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
Default locale: en_US, platform encoding: MacRoman
OS name: "mac os x", version: "10.7.2", arch: "x86_64", family: "mac"

-- 
Alasdair Nottingham
not@apache.org

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message