aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Jencks (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ARIES-817) Upgrade to asm 4 for java 7 support
Date Fri, 27 Jan 2012 09:20:42 GMT

     [ https://issues.apache.org/jira/browse/ARIES-817?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

David Jencks updated ARIES-817:
-------------------------------

    Attachment: ARIES-817-spi-fly.diff

Most of spi-fly is easy to fix... would it be possible to pull in the proxy modules' osgi
friendly class writer rather than copying the code?

I'd suggest waiting to commit this until I'm more sure the new code works with the rest of
aries, but I could commit it now if you'd like.
                
> Upgrade to asm 4 for java 7 support
> -----------------------------------
>
>                 Key: ARIES-817
>                 URL: https://issues.apache.org/jira/browse/ARIES-817
>             Project: Aries
>          Issue Type: Improvement
>          Components: Application, Blueprint, Proxy
>            Reporter: David Jencks
>            Assignee: David Jencks
>         Attachments: ARIES-817-spi-fly.diff
>
>
> asm 3 generates java 7 incompatible classes.  We need to upgrade to asm 4 to be able
to support running on java 7.  There are a few simple code changes needed in the proxy module,
and a couple nasty workarounds for newly final methods and private fields.  There is also
a lot of work in integration tests and pom versions to make everything else work.
> I plan to add patches here as I proceed and when everything works I'll think about committing.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message