aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Nuttall <mnutt...@apache.org>
Subject Build breaks and Eclipselink woes
Date Fri, 20 Jan 2012 11:03:53 GMT
Hello,
The most recent Apache Aries hudson build has a number of test failures:
https://builds.apache.org/job/Aries/1325/.

Problems with the Eclipselink maven repository are preventing me from even
reproducing these problems, let alone investigating them. From a clean
local environment, it is not currently possible to build any modules with
eclipselink dependencies. One sees errors of the form,

[INFO] Unable to find resource
'org.eclipse.persistence:org.eclipse.persistence.
jpa:jar:2.1.0' in repository EclipseLink Repo (
http://www.mirrorservice.org/site
s/download.eclipse.org/eclipseMirror/rt/eclipselink/maven.repo/)
Downloading:
http://repo1.maven.org/maven2/org/eclipse/persistence/org.eclipse.p
ersistence.jpa/2.1.0/org.eclipse.persistence.jpa-2.1.0.jar
[INFO] Unable to find resource
'org.eclipse.persistence:org.eclipse.persistence.
jpa:jar:2.1.0' in repository central (http://repo1.maven.org/maven2)
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Failed to resolve artifact.

Missing:
----------
1) org.eclipse.persistence:org.eclipse.persistence.jpa:jar:2.1.0


I believe that this stems from problems in the configuration of the
eclipselink maven repository. Although Hudson isn't failing with this
error, it is preventing any efforts at diagnosing the other build
breaks. As a first step I need to remove eclipselink and its dependent
tests until these build problems can be resolved. I will also raise JIRAs
for any remaining failing tests, given my team's need for a goodHudson
build.

Regards,
Mark

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message