aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emily Jiang <emijia...@googlemail.com>
Subject Re: [jira] [Updated] (ARIES-903) Import-Service requirement not compatible with clauses coming from Felix bundlerepository
Date Thu, 09 Aug 2012 08:01:40 GMT
The Import-Service header in the bundle's manifest is deprecated and we
don't claim to support it. Therefore, we did not use the exactly filter
string as specified in the out-of-date rfc112. The syntax you saw is the
blueprint service modelling, which is used to model the deprecated import
service. The filter works fine with the repository xml generated by apache
aries, which may have some issues if you plug in external bundle
repositoories with import or export services generated by other tools.

By the way, in the near future, the whole provisioning will move up to the
OSGi V5 resolver and repository or subsystem spec. I am not sure it worthes
the fix this unless you have very strong reason for it to be fixed.

Regards
Emily
On Thu, Aug 9, 2012 at 8:02 AM, Tuomas Kiviaho (JIRA) <jira@apache.org>wrote:

>
>      [
> https://issues.apache.org/jira/browse/ARIES-903?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel]
>
> Tuomas Kiviaho updated ARIES-903:
> ---------------------------------
>
>     Attachment: ImportedServiceTransformer.java
>
> Here's a temporary workaround for the problem using bundle resource
> transformer (which had to be registered using instance method but was used
> via in static method?)
>
> > Import-Service requirement not compatible with clauses coming from Felix
> bundlerepository
> >
> -----------------------------------------------------------------------------------------
> >
> >                 Key: ARIES-903
> >                 URL: https://issues.apache.org/jira/browse/ARIES-903
> >             Project: Aries
> >          Issue Type: Bug
> >          Components: Application
> >            Reporter: Tuomas Kiviaho
> >         Attachments: ImportedServiceTransformer.java
> >
> >
> >
> org.apache.felix.bundlerepository.impl.DataModelHelperImpl.doImportExportServices()
> produces service import requirement filters in form of
> (service=org.osgi.service.packageadmin.PackageAdmin) but
> org.apache.aries.application.modelling.impl.ImportedServiceImpl generates
> an attribute filter that doesn't match to it. (&(service=service
> (objectClass=org.osgi.service.packageadmin.PackageAdmin))
> >
> > I assume that service exports function similarly.
> > The problem can be replicated by trying to install
> org.apache.felix.shell version 1.4.3 that imports package admin service
> shown in example (from felix 4.0.3)
> > PS. The actual problem might be at bundlerepository end because I have
> no idea which of the forms is the correct one.
>
> --
> This message is automatically generated by JIRA.
> If you think it was sent incorrectly, please contact your JIRA
> administrators:
> https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
> For more information on JIRA, see: http://www.atlassian.com/software/jira
>
>
>


-- 
Thanks
Emily
=================
Emily Jiang
ejiang@apache.org

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message