aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: Releases....
Date Mon, 04 Feb 2013 16:18:01 GMT

On Feb 3, 2013, at 11:13 AM, Rex Wang <rwonly@gmail.com> wrote:

> hi, Daniel, David,
> Glad to know you are trying release the spi-fly 1.0. Any updates? Looking
> forward the reference implementation of the OSGi Service Loader mediator
> spec:-)

Haven't had time… it looks like I'll need to do another JMX release very shortly due to
version range issues.  :-(   I'll try and include it in that process.

Dan



> - Rex
> 
> 2013/1/24 Emily Jiang <emijiang6@googlemail.com>
> 
>> Saw your email later. Glad you have sorted out. In the future, it will be
>> the developer who check in changes and then maintain the versions, so
>> she/he can decide what to do when there is a need to bump up the major
>> version.
>> Thanks
>> Emily
>> 
>> On Wed, Jan 23, 2013 at 7:57 PM, Daniel Kulp <dkulp@apache.org> wrote:
>> 
>>> 
>>> Looks like David and I managed to sort this out.   I'll proceed with the
>>> JMX stuff.
>>> 
>>> Dan
>>> 
>>> 
>>> 
>>> On Jan 23, 2013, at 11:37 AM, Daniel Kulp <dkulp@apache.org> wrote:
>>> 
>>>> 
>>>> On Jan 23, 2013, at 11:26 AM, Daniel Kulp <dkulp@apache.org> wrote:
>>>> 
>>>>> Ah…  there are some incompatible changes in org.apache.aries.jmx.codec
>>> that the version checker is flagging causing it to force it up to 2.0.
>>> I'll see if I can make that package compatible enough to keep it 1.1.0.
>>>> 
>>>> OK.   I added back in some constructors which is allowing it to drop to
>>> 1.1.0-SNAPSHOT.
>>>> 
>>>> David:  can you double check to make sure that change is OK?     Also,
>>> should I mark those constructors @Deprecated or not?
>>>> 
>>>> 
>>>> Dan
>>>> 
>>>> 
>>>> 
>>>>> 
>>>>> Dan
>>>>> 
>>>>> 
>>>>> On Jan 23, 2013, at 11:16 AM, David Bosschaert <
>>> david.bosschaert@gmail.com> wrote:
>>>>> 
>>>>>> I would have thought that it should be version 1.1.0-SNAPSHOT. That's
>>> what
>>>>>> I used when I committed the file from jmx-next.
>>>>>> 
>>>>>> However I see that the version has been bumped to 2.0.0-SNAPSHOT
by
>>> Emily
>>>>>> in revision 1424200:
>>>>>> Revision: 1424200
>>>>>> Author: ejiang
>>>>>> Date: 19 December 2012 22:57:24
>>>>>> Message:
>>>>>> ARIES-979: Integrate semantic versioning maven plugin in aries
>> modules
>>>>>> (jmx)
>>>>>> 
>>>>>> Maybe Emily has an idea why it got bumped, but if you ask me it
>> should
>>> be
>>>>>> 1.1...
>>>>>> 
>>>>>> Cheers,
>>>>>> 
>>>>>> David
>>>>>> 
>>>>>> On 23 January 2013 15:56, Daniel Kulp <dkulp@apache.org> wrote:
>>>>>> 
>>>>>>> 
>>>>>>> David,
>>>>>>> 
>>>>>>> I just noticed that jmx-api is now at version 2.0.0-SNAPSHOT,
yet it
>>> says
>>>>>>> it implements the 1.1 API?   Is the version number there correct?
>>> Kind of
>>>>>>> concerned about that version number as it would be outside the
>> normal
>>>>>>> import range for existing bundles (likely [1.0,2) ).
>>>>>>> 
>>>>>>> 
>>>>>>> 
>>>>>>> Dan
>>>>>>> 
>>>>>>> 
>>>>>>> 
>>>>>>> On Jan 22, 2013, at 1:04 PM, Daniel Kulp <dkulp@apache.org>
wrote:
>>>>>>> 
>>>>>>>> 
>>>>>>>> I've updated the aries builds to grab the released plugin.
 Things
>>> look
>>>>>>> OK so I'm likely going to do a bunch of release builds tomorrow.
>>> Talking
>>>>>>> to Guillaume and digging through the various commit logs and
such,
>> it
>>> looks
>>>>>>> like I'll need:
>>>>>>>> 
>>>>>>>> util-r2
>>>>>>>> util
>>>>>>>> proxy-impl
>>>>>>>> proxy-bundle
>>>>>>>> blueprint-core
>>>>>>>> blueprint-cm
>>>>>>>> blueprint-bundle
>>>>>>>> jmx-api
>>>>>>>> jmx-core
>>>>>>>> jmx-blueprint-core
>>>>>>>> jmx-bundle
>>>>>>>> jmx-blueprint-bundle
>>>>>>>> transaction-blueprint
>>>>>>>> jpa-blueprint-aries
>>>>>>>> blueprint-itests
>>>>>>>> blueprint-testbundleb
>>>>>>>> 
>>>>>>>> If there are no objections, I'm going to blast through them
all
>>>>>>> tomorrow.   If you have any additional updates or changes, please
>>> speak up
>>>>>>> now.  Thanks!
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> --
>>>>>>>> Daniel Kulp
>>>>>>>> dkulp@apache.org - http://dankulp.com/blog
>>>>>>>> Talend Community Coder - http://coders.talend.com
>>>>>>>> 
>>>>>>> 
>>>>>>> --
>>>>>>> Daniel Kulp
>>>>>>> dkulp@apache.org - http://dankulp.com/blog
>>>>>>> Talend Community Coder - http://coders.talend.com
>>>>>>> 
>>>>>>> 
>>>>> 
>>>>> --
>>>>> Daniel Kulp
>>>>> dkulp@apache.org - http://dankulp.com/blog
>>>>> Talend Community Coder - http://coders.talend.com
>>>>> 
>>>> 
>>>> --
>>>> Daniel Kulp
>>>> dkulp@apache.org - http://dankulp.com/blog
>>>> Talend Community Coder - http://coders.talend.com
>>>> 
>>> 
>>> --
>>> Daniel Kulp
>>> dkulp@apache.org - http://dankulp.com/blog
>>> Talend Community Coder - http://coders.talend.com
>>> 
>>> 
>> 
>> 
>> --
>> Thanks
>> Emily
>> =================
>> Emily Jiang
>> ejiang@apache.org
>> 
> 
> 
> 
> -- 
> Lei Wang (Rex)
> rwonly AT apache.org

-- 
Daniel Kulp
dkulp@apache.org - http://dankulp.com/blog
Talend Community Coder - http://coders.talend.com


Mime
View raw message