aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kulp (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (ARIES-1013) Aries JMX Core should extend its OSGi framework version range
Date Fri, 01 Feb 2013 17:02:14 GMT

     [ https://issues.apache.org/jira/browse/ARIES-1013?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Daniel Kulp resolved ARIES-1013.
--------------------------------

    Resolution: Fixed
    
> Aries JMX Core should extend its OSGi framework version range
> -------------------------------------------------------------
>
>                 Key: ARIES-1013
>                 URL: https://issues.apache.org/jira/browse/ARIES-1013
>             Project: Aries
>          Issue Type: Bug
>          Components: JMX
>         Environment: Aries JMX 1.1.0
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Daniel Kulp
>         Attachments: ARIES-1013.patch
>
>
> In order to work with "all" OSGi frameworks, Aries JMX bundle should extend its org.osgi.framework
package version range (to something like [1.6,2)):
> Bundle org.apache.aries.jmx.core [65] Error starting mvn:org.apache.aries.jmx/org.apache.aries.jmx.core/1.1.0
(org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.core
[65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))))
> org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.core
[65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0)))
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
>         at java.lang.Thread.run(Thread.java:662)
> laERROR: Bundle org.apache.aries.jmx.core [65] Error starting/stopping bundle. (org.osgi.framework.BundleException:
Unresolved constraint in bundle org.apache.aries.jmx.core [65]: Unable to resolve 65.0: missing
requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))))
> org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.core
[65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0)))
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
>         at org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1388)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:301)
>         at java.lang.Thread.run(Thread.java:662)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message