aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kulp (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ARIES-1015) Use version range in imported package
Date Tue, 05 Feb 2013 14:37:14 GMT

    [ https://issues.apache.org/jira/browse/ARIES-1015?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13571343#comment-13571343
] 

Daniel Kulp commented on ARIES-1015:
------------------------------------

This patch has a few:

{code}
-            org.osgi.framework;version="[1.5,2)",
+            org.osgi.framework;version="[1.6,2)",
{code}

Is it really intentional to require 1.6?   Is everyone OK with updating that?  

I'm not sure if we agreed to drop the 1.5 support for the various components.  Thoughts?
                
> Use version range in imported package
> -------------------------------------
>
>                 Key: ARIES-1015
>                 URL: https://issues.apache.org/jira/browse/ARIES-1015
>             Project: Aries
>          Issue Type: Improvement
>            Reporter: Jean-Baptiste Onofré
>         Attachments: ARIES-1015.patch
>
>
> As seen in Aries JMX, some other modules should use version range for imported package
in order to be aligned with at least OSGi r4.3.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message