aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Ross (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ARIES-1057) README Updates
Date Wed, 04 Sep 2013 13:57:51 GMT

     [ https://issues.apache.org/jira/browse/ARIES-1057?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

John Ross updated ARIES-1057:
-----------------------------

    Description: 
Subsystems requires an R5 compliant framework implementation. This should be mentioned in
the README.

Required bundle versions should be updated to reflect recent releases of util, proxy, subsystems,
and resolver.

Add org.eclipse.equinox.supplement to list of required bundles. See ARIES-1053.

Discuss service dependency resolution and limitations thereof, especially for applications.
See ARIES-1108.

Add slf4j-api and slf4j-simple to list of required bundles.

Add org.osgi.enterprise-5.0.0 to list of required bundles.

Add org.apache.felix.bundlerepository to list of required bundles when subsystem-obr is installed.

  was:
Subsystems requires an R5 compliant framework implementation. This should be mentioned in
the README.

Required bundle versions should be updated to reflect recent releases of util, proxy, subsystems,
and resolver.

Add org.eclipse.equinox.supplement to list of required bundles. See ARIES-1053.

Discuss service dependency resolution and limitations thereof, especially for applications.
See ARIES-1108.

Add slf4j-api and slf4j-simple to list of required bundles.

Add org.osgi.enterprise-5.0.0 to list of required bundles.

    
> README Updates
> --------------
>
>                 Key: ARIES-1057
>                 URL: https://issues.apache.org/jira/browse/ARIES-1057
>             Project: Aries
>          Issue Type: Documentation
>          Components: Subsystem
>            Reporter: John Ross
>
> Subsystems requires an R5 compliant framework implementation. This should be mentioned
in the README.
> Required bundle versions should be updated to reflect recent releases of util, proxy,
subsystems, and resolver.
> Add org.eclipse.equinox.supplement to list of required bundles. See ARIES-1053.
> Discuss service dependency resolution and limitations thereof, especially for applications.
See ARIES-1108.
> Add slf4j-api and slf4j-simple to list of required bundles.
> Add org.osgi.enterprise-5.0.0 to list of required bundles.
> Add org.apache.felix.bundlerepository to list of required bundles when subsystem-obr
is installed.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message