aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Hughes <jpjhug...@gmail.com>
Subject Re: Problem to compile Aries Jpa sources
Date Wed, 22 Jan 2014 18:23:51 GMT
Hi, we have a problem building with Maven 3.1.x and some modules have
a problem with Java 7. Could you try with Maven 3.0.5 and Java 6?

Thanks,
Jeremy

On 22 January 2014 14:32, Giuseppe Gerla <giuseppe.gerla@gmail.com> wrote:
> Hi all
> I need to use eclipselink 2.5.1 in Karaf container.
> I try to use Aries Jpa 1.0.0 and I have some problems.
> First of all I need to install
> also org.apache.aries.jpa.eclipselink.adapter but this bundle is not
> compliance with new version of Aries Jpa.
> So I checkout sources and modified the pom file.
> After this I have some problem with eclipselink version, because with 2.4.2
> all works fine, but with 2.5.1 I have a cast exception. This is because the
> 2.5.1 version use the javax.pesistence 2.1.0 and this vesion is excluded in
> the import package of Aries Jpa Container bundle.
>
> I'd like to modify the pom but I'm not able to compile the aries jpa
> sources.
>
> If i run mvn -version i can read
>
> Apache Maven 3.1.0 (893ca28a1da9d5f51ac03827af98bb730128f9f2; 2013-06-28
> 04:15:32+0200)
> Maven home: D:\Dev\maven-3.1.0
> Java version: 1.7.0_45, vendor: Oracle Corporation
> Java home: C:\Program Files (x86)\Java\jdk1.7.0_45\jre
> Default locale: it_IT, platform encoding: Cp1252
> OS name: "windows 7", version: "6.1", arch: "x86", family: "windows"
>
>
> Can you help me?

Mime
View raw message