aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mikaël Barbero (JIRA) <j...@apache.org>
Subject [jira] [Updated] (ARIES-1159) NPE in org.apache.aries.versioning.plugin
Date Wed, 26 Feb 2014 10:46:19 GMT

     [ https://issues.apache.org/jira/browse/ARIES-1159?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Mikaël Barbero updated ARIES-1159:
----------------------------------

    Description: 
Hi, 

I'm trying to support semantic versioning of exported packages on Guava (https://code.google.com/p/guava-libraries/issues/detail?id=1682)
with the help of the plugin org.apache.aries.versioning:org.apache.aries.versioning.plugin.

Unfortunately, I hit a NPE when trying to do the build:

[ERROR] Failed to execute goal org.apache.aries.versioning:org.apache.aries.versioning.plugin:0.1.0:version-check
(default-verify) on project guava: Execution default-verify of goal org.apache.aries.versioning:org.apache.aries.versioning.plugin:0.1.0:version-check
failed. NullPointerException -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.aries.versioning:org.apache.aries.versioning.plugin:0.1.0:version-check
(default-verify) on project guava: Execution default-verify of goal org.apache.aries.versioning:org.apache.aries.versioning.plugin:0.1.0:version-check
failed.
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:225)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
	at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
	at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
Caused by: org.apache.maven.plugin.PluginExecutionException: Execution default-verify of goal
org.apache.aries.versioning:org.apache.aries.versioning.plugin:0.1.0:version-check failed.
	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:110)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
	... 19 more
Caused by: java.lang.NullPointerException
	at org.apache.aries.versioning.check.BundleCompatibility.visitPackage(BundleCompatibility.java:302)
	at org.apache.aries.versioning.check.BundleCompatibility.invoke(BundleCompatibility.java:133)
	at org.apache.aries.versioning.mojo.VersionCheckerMojo.execute(VersionCheckerMojo.java:128)
	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
	... 20 more
[ERROR] 

You can find the experiment @ https://github.com/mbarbero/guava-libraries/tree/issue1682

  was:
Hi, 

I'm trying to support semantic versioning of exported packages on Guava (https://code.google.com/p/guava-libraries/issues/detail?id=1682)
with the help of the plugin org.apache.aries.versioning:org.apache.aries.versioning.plugin.

Unfortunately, I hit a NPE when trying to do the build:

[ERROR] Failed to execute goal org.apache.aries.versioning:org.apache.aries.versioning.plugin:0.1.0:version-check
(default-verify) on project guava: Execution default-verify of goal org.apache.aries.versioning:org.apache.aries.versioning.plugin:0.1.0:version-check
failed. NullPointerException -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.aries.versioning:org.apache.aries.versioning.plugin:0.1.0:version-check
(default-verify) on project guava: Execution default-verify of goal org.apache.aries.versioning:org.apache.aries.versioning.plugin:0.1.0:version-check
failed.
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:225)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
	at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
	at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
Caused by: org.apache.maven.plugin.PluginExecutionException: Execution default-verify of goal
org.apache.aries.versioning:org.apache.aries.versioning.plugin:0.1.0:version-check failed.
	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:110)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
	... 19 more
Caused by: java.lang.NullPointerException
	at org.apache.aries.versioning.check.BundleCompatibility.visitPackage(BundleCompatibility.java:302)
	at org.apache.aries.versioning.check.BundleCompatibility.invoke(BundleCompatibility.java:133)
	at org.apache.aries.versioning.mojo.VersionCheckerMojo.execute(VersionCheckerMojo.java:128)
	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
	... 20 more
[ERROR] 

You an find the experiment @ https://github.com/mbarbero/guava-libraries/tree/issue1682


> NPE in org.apache.aries.versioning.plugin
> -----------------------------------------
>
>                 Key: ARIES-1159
>                 URL: https://issues.apache.org/jira/browse/ARIES-1159
>             Project: Aries
>          Issue Type: Bug
>            Reporter: Mikaël Barbero
>
> Hi, 
> I'm trying to support semantic versioning of exported packages on Guava (https://code.google.com/p/guava-libraries/issues/detail?id=1682)
with the help of the plugin org.apache.aries.versioning:org.apache.aries.versioning.plugin.
> Unfortunately, I hit a NPE when trying to do the build:
> [ERROR] Failed to execute goal org.apache.aries.versioning:org.apache.aries.versioning.plugin:0.1.0:version-check
(default-verify) on project guava: Execution default-verify of goal org.apache.aries.versioning:org.apache.aries.versioning.plugin:0.1.0:version-check
failed. NullPointerException -> [Help 1]
> org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.aries.versioning:org.apache.aries.versioning.plugin:0.1.0:version-check
(default-verify) on project guava: Execution default-verify of goal org.apache.aries.versioning:org.apache.aries.versioning.plugin:0.1.0:version-check
failed.
> 	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:225)
> 	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
> 	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
> 	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
> 	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
> 	at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
> 	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
> 	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
> 	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
> 	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
> 	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
> 	at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
> 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
> 	at java.lang.reflect.Method.invoke(Method.java:606)
> 	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
> 	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
> 	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
> 	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
> Caused by: org.apache.maven.plugin.PluginExecutionException: Execution default-verify
of goal org.apache.aries.versioning:org.apache.aries.versioning.plugin:0.1.0:version-check
failed.
> 	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:110)
> 	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
> 	... 19 more
> Caused by: java.lang.NullPointerException
> 	at org.apache.aries.versioning.check.BundleCompatibility.visitPackage(BundleCompatibility.java:302)
> 	at org.apache.aries.versioning.check.BundleCompatibility.invoke(BundleCompatibility.java:133)
> 	at org.apache.aries.versioning.mojo.VersionCheckerMojo.execute(VersionCheckerMojo.java:128)
> 	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
> 	... 20 more
> [ERROR] 
> You can find the experiment @ https://github.com/mbarbero/guava-libraries/tree/issue1682



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message