aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harald Wellmann (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ARIES-1185) SPI Fly does not work with Java 8
Date Mon, 26 May 2014 13:10:01 GMT

    [ https://issues.apache.org/jira/browse/ARIES-1185?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14008826#comment-14008826
] 

Harald Wellmann commented on ARIES-1185:
----------------------------------------

BTW, I've just hacked and tested this locally. Upgrading to ASM 5.0.2 appears to be enough
indeed. The POMs need some tweaking to build under Java 7 or 8. I can submit a pull request
if desired.

As a workaround, users can modify the Import-Package header (e.g. using Pax URL Wrap) to include
ASM 5.x.

> SPI Fly does not work with Java 8
> ---------------------------------
>
>                 Key: ARIES-1185
>                 URL: https://issues.apache.org/jira/browse/ARIES-1185
>             Project: Aries
>          Issue Type: Bug
>            Reporter: David Bosschaert
>
> The SPI Fly component does not work with Java 8 due to the ASM version being used not
being compatible with Java 8. 
> Upgrading ASM to the latest version should fix the issue.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message