aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: current aries build issues
Date Thu, 05 Jun 2014 18:06:58 GMT

Everything should now compile with Java6 and Maven 3.2.1.    

Tests are another story……..

Haven’t re-checked with Java 7 and Java 8.


Dan



On Jun 5, 2014, at 1:14 PM, Daniel Kulp <dkulp@apache.org> wrote:

> 
> On Jun 5, 2014, at 12:22 PM, Samuel E Bratton <sbratton@us.ibm.com> wrote:
> 
>> Hi,
>> 
>> The Aries builds have been red for about the last 5 days. It looks like a 
>> couple of different people have been working on fixing it. Is this a 
>> coordinated effort? Are there a particular set of JIRAs where this is 
>> going on and can be followed?
> 
> From what I can tell, there are (at least) three efforts around the builds:
> 
> 1) Update to support Maven 3.1/3.2 - I’m primarily working on this.  Mostly just trying
to get things to compile/build with the newer Maven versions.  Haven’t really targeted any
tests yet.
> 
> 2) Update to support Java 8 - this is kind of two parts:  (a) build with java 8,  and
(b) tests run with java8.   I believe JB is working on this.
> 
> 3) Update to newer versions of Pax-exam - the version we were using is very ancient.
 We’re trying to get up to a more modern version.   Christian has been working on this a
bit.
> 
> 
> Some of the instability right now I *think* is related to #2.   Getting everything updated
to use the new ASM and not have various conflicts and such is taking bit of time.  Any help
getting tests to pass again would be great.
> 
> 
> -- 
> Daniel Kulp
> dkulp@apache.org - http://dankulp.com/blog
> Talend Community Coder - http://coders.talend.com
> 

-- 
Daniel Kulp
dkulp@apache.org - http://dankulp.com/blog
Talend Community Coder - http://coders.talend.com


Mime
View raw message