aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: compiling subsystems itests failing
Date Thu, 05 Jun 2014 10:56:19 GMT
Hi Sam,

OSGi 4.3.1 should work too.

Regards
JB

On 06/05/2014 02:11 AM, Samuel E Bratton wrote:
> Thanks, Putting org.osgi.core-5.0.0.jar as a first dependency did allow me
> to compile everything.
>
> Guillaume Nodet <gnodet@apache.org> wrote on 06/04/2014 04:48:42 PM:
>
>> From: Guillaume Nodet <gnodet@apache.org>
>> To: dev@aries.apache.org
>> Date: 06/04/2014 04:49 PM
>> Subject: Re: compiling subsystems itests failing
>>
>> Mmh, actually, I haven't touched this one.
>> For other modules, what I did is to add dependencies on osgi.core and
>> eventually osgi.compendium at the top of the dependencies list so that
> they
>> end-up first in the classpath.  Can you try something like that ?
>>
>>
>> 2014-06-04 23:33 GMT+02:00 Samuel E Bratton <sbratton@us.ibm.com>:
>>
>>> I'm still seeing it after updating just now. How did you fix it?
>>>
>>> Thanks
>>> Sam Bratton
>>>
>>> Guillaume Nodet <gnodet@apache.org> wrote on 06/04/2014 03:44:05 PM:
>>>
>>>> From: Guillaume Nodet <gnodet@apache.org>
>>>> To: dev@aries.apache.org
>>>> Date: 06/04/2014 03:44 PM
>>>> Subject: Re: compiling subsystems itests failing
>>>>
>>>> I think I fixed that yesterday, it seems to work for me on latest
> trunk.
>>>>
>>>>
>>>> 2014-06-04 22:41 GMT+02:00 Samuel E Bratton <sbratton@us.ibm.com>:
>>>>
>>>>> I'm also having issues building aries on the subssystem itests.
> It's
>>> been
>>>>> failing the last few days including with the latest updates from
> this
>>>>> morning. I see multiple compile errors. It looks like
> non-Genericized
>>>>> classes being used with generics, for example
>>>>>
>>>>> ~/aries/subsystem/subsystem-itests mvn clean install
>>>>> ...
>>>>>
>>>>> [ERROR]
>>>>>
>>>>> /C:/cygwin/home/sbratton/ariesJ7/aries/subsystem/subsystem-itests/
>>>>
>>>
> src/test/java/org/apache/aries/subsystem/itests/SubsystemTest.java:[248,49]
>>>>> type org.osgi.framework.ServiceRegistration does not take
> parameters
>>>>> ...
>>>>>
>>>>> on this line of code:
>>>>> 248:    protected Collection<ServiceRegistration<?>>
>>> serviceRegistrations
>>>>> = new ArrayList<ServiceRegistration<?>>();
>>>>>
>>>>> as far as I can tell from the mvn debug messages the version of
>>>>> ServiceRegistration is from
> org.eclipse.osgi-3.8.0.v20120529-1548.jar
>>>>>
>>>>> Anybody know what's causing thsi?
>>>>>
>>>>> --
>>>>> Samuel Bratton
>>>
>>>
>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message