aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: Current build and org.eclipse.osgi version 3.8.2.v20130124-134944
Date Wed, 04 Jun 2014 14:56:52 GMT

On Jun 4, 2014, at 10:54 AM, Thomas Watson <tjwatson@us.ibm.com> wrote:

> Daniel Kulp has fixed the pom to point back to the 3.8.0 version so the build seems to
work for me again.  Thanks!
> 

I think the tests are failing, but at least we can build.  One step at a timeā€¦..

Dan



> 
> Tom
> 
> 
> 
> Thomas Watson---06/04/2014 08:06:44 AM---Hi David, I don't think that is the case here.
 This is blueprint and the pom was
> 
> From:	Thomas Watson/Austin/IBM@IBMUS
> To:	dev@aries.apache.org
> Date:	06/04/2014 08:06 AM
> Subject:	Re: Current build and org.eclipse.osgi version 3.8.2.v20130124-134944
> 
> 
> 
> Hi David,
> 
> I don't think that is the case here.  This is blueprint and the pom was updated to simply
refer to a new version of equinox.  I suspect it built locally because the developers local
m2 cache likely has the version configured manually.  But shouldn't the aries build be setup
to work without manual configuration of the local m2 cache?  Is there not an aries maven repo
we can use to place the dependencies we need such as equinox?
> 
> Tom
> 
> 
> 
> David Bosschaert ---06/04/2014 01:49:04 AM---It might be downloading it from somewhere
(using something like a http get task) and then using a sy
> 
> From: David Bosschaert <david.bosschaert@gmail.com>
> To: "dev@aries.apache.org" <dev@aries.apache.org>
> Date: 06/04/2014 01:49 AM
> Subject: Re: Current build and org.eclipse.osgi version 3.8.2.v20130124-134944
> 
> 
> 
> It might be downloading it from somewhere (using something like a http
> get task) and then using a system dependency to use it in Maven. Not
> sure this is the way its used in this particular place, but I think
> the subsystems subproject had certain Eclipse dependencies set up this
> way.
> 
> John Ross might be able to give more details...
> 
> Cheers,
> 
> David
> 
> On 3 June 2014 20:37, Thomas Watson <tjwatson@us.ibm.com> wrote:
> >
> > With the latest from trunk I am no longer able to build because of a
> > reference to org.eclipse:org.eclipse.osgi:jar:3.8.2.v20130124-134944
> >
> > Which repo is this supposed to exist?  Here is the error.
> >
> > Failed to execute goal on project org.apache.aries.blueprint.itests: Could
> > not resolve dependencies for project
> > org.apache.aries.blueprint:org.apache.aries.blueprint.itests:jar:1.0.2-SNAPSHOT:
> >  Could not find artifact
> > org.eclipse:org.eclipse.osgi:jar:3.8.2.v20130124-134944 in EclipseLink Repo
> > (http://download.eclipse.org/rt/eclipselink/maven.repo/)
> >
> > Tom
> 
> 

-- 
Daniel Kulp
dkulp@apache.org - http://dankulp.com/blog
Talend Community Coder - http://coders.talend.com


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message