aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Bosschaert (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (ARIES-1255) esa-maven-plugin generates Subsystem-Content with version range for composite subsystems
Date Fri, 03 Oct 2014 14:31:34 GMT

     [ https://issues.apache.org/jira/browse/ARIES-1255?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

David Bosschaert resolved ARIES-1255.
-------------------------------------
    Resolution: Fixed

Fixed in http://svn.apache.org/viewvc?view=revision&revision=1629208

> esa-maven-plugin generates Subsystem-Content with version range for composite subsystems
> ----------------------------------------------------------------------------------------
>
>                 Key: ARIES-1255
>                 URL: https://issues.apache.org/jira/browse/ARIES-1255
>             Project: Aries
>          Issue Type: Bug
>            Reporter: David Bosschaert
>            Assignee: David Bosschaert
>
> Subsystem-Content is derived from the project artifacts. However currently the version
range is produced as version="x.y.z" which does not have an upper bound.
> This is not valid for composite subsystems, as they need a specific version.
> However, I think in general this is not desirable for other subsystems either.
> The default should be "[x.y.z, x.y.z]" for all Subsystem-Content derived from maven dependencies
as they point at a specific version.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message