aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Valérian Sourceaux (JIRA) <>
Subject [jira] [Commented] (ARIES-1137) Managed properties are not injected at initialization phase
Date Thu, 26 Feb 2015 16:14:07 GMT


Valérian Sourceaux commented on ARIES-1137:

I tried to migrate a big application based on Karaf 2.0.3 with SpringDM to Karaf 3.0.3 with
Blueprint. First attempt with Eclipse Gemini did not work, so I tried Aries implementation.
I'm stuck because of this bug as my services are not getting the configuration and thus are
not initialized upon startup.
I've tried your latest fix from SVN, but with no more success, to me it doesn't resolve the
I've also been testing against previous blueprint-cm versions starting from 1.0.0. I'm getting
"is waiting for namespace handlers" issue on both 1.0.0 and 1.0.2, and for all other versions,
the behaviour on managed-properties is the same as 1.0.5.
So it seems this bug comes from an earlier version than 1.0.4.

> Managed properties are not injected at initialization phase
> -----------------------------------------------------------
>                 Key: ARIES-1137
>                 URL:
>             Project: Aries
>          Issue Type: Bug
>          Components: Blueprint
>    Affects Versions: blueprint-cm-1.0.4
>         Environment: blueprint-cm 1.0.1 under karaf 2.3.3
>            Reporter: Łukasz Dywicki
>            Assignee: Christian Schneider
>            Priority: Critical
>              Labels: blueprint, xml
>             Fix For: blueprint-cm-1.0.6
> The cm:managed-properties element do not cause initial call of update method any longer.
Even if configuration contains properties they are not put as long as changes are not done
in it, which means that after restart managed component is not initialized correctly.

This message was sent by Atlassian JIRA

View raw message