aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Bosschaert <david.bosscha...@gmail.com>
Subject Re: Failing Subsystem iTest Build
Date Tue, 24 Mar 2015 13:57:52 GMT
Well, I think it's not as easy as it sounds :)

For separate itest components (like the one below), you definitely
want to depend on the *current* SNAPSHOT components of the ones that
are being tested by tests, otherwise the test components test a
previous release of the current component - I just spotted that the
subsystem-itests were still testing the SNAPSHOTs of the previous
release, I have just fixed that.

Dependencies on other communities should normally use released versions.

Cheers,

David

On 24 March 2015 at 13:46, Kamesh Sampath <kamesh.sampath@liferay.com> wrote:
> perfect works, build is successful now. As of now i don't see any other failed builds
but will it be worth making these kind of stable version changes across ARIES build ?
>
>
>> On 24-Mar-2015, at 6:09 pm, David Bosschaert <david.bosschaert@gmail.com> wrote:
>>
>> Hi Kamesh,
>>
>> Thanks for this!
>>
>> I have updated the Felix Resolver dependency to 1.0.0 as there is no
>> need for a SNAPSHOT dependency here.
>>
>> Best regards,
>>
>> David
>>
>>
>> On 24 March 2015 at 13:29, Kamesh Sampath <kamesh.sampath@liferay.com> wrote:
>>> the Subsystem build on the latest sources fails with the following trace, doing
clan of ~/.m2 felix resolver folders does not help.
>>>
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] Building Apache Aries Subsystem iTests 1.1.0-SNAPSHOT
>>> [INFO] ------------------------------------------------------------------------
>>> Downloading: http://localhost:8081/artifactory/libs-snapshot/org/apache/felix/org.apache.felix.resolver/0.1.0-SNAPSHOT/maven-metadata.xml
>>> Downloading: http://localhost:8081/artifactory/libs-snapshot/org/apache/felix/org.apache.felix.resolver/0.1.0-SNAPSHOT/org.apache.felix.resolver-0.1.0-SNAPSHOT.pom
>>> [WARNING] The POM for org.apache.felix:org.apache.felix.resolver:jar:0.1.0-SNAPSHOT
is missing, no dependency information available
>>> Downloading: http://localhost:8081/artifactory/libs-snapshot/org/apache/felix/org.apache.felix.resolver/0.1.0-SNAPSHOT/org.apache.felix.resolver-0.1.0-SNAPSHOT.jar
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] Reactor Summary:
>>> [INFO]
>>> [INFO] Apache Aries Subsystem iTests ...................... FAILURE [  2.211
s]
>>> [INFO] Apache Aries Subsystems Bundle ..................... SKIPPED
>>> [INFO] Apache Aries Subsystem ............................. SKIPPED
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] BUILD FAILURE
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] Total time: 4.487 s
>>>
>>>
>>> The solution would be to bump the org.apache.felix.resolver bundle version to
1.1.0-SNAPSHOT or more appropriate version thats suitable.
>>>
>>> The following dependency update on the subsystem iTests project made the build
run successfully.
>>>
>>> <dependency>
>>>            <groupId>org.apache.felix</groupId>
>>>            <artifactId>org.apache.felix.resolver</artifactId>
>>>            <version>1.1.0-SNAPSHOT</version>
>>>            <exclusions>
>>>                <exclusion>
>>>                    <groupId>org.osgi</groupId>
>>>                    <artifactId>org.osgi.core</artifactId>
>>>                </exclusion>
>>>                <exclusion>
>>>                    <groupId>org.apache.felix</groupId>
>>>                    <artifactId>org.osgi.core</artifactId>
>>>                </exclusion>
>>>                <exclusion>
>>>                    <groupId>org.osgi</groupId>
>>>                    <artifactId>org.osgi.compendium</artifactId>
>>>                </exclusion>
>>>            </exclusions>
>>> </dependency>
>>>
>>> Thank you.
>>>
>>> -Kamesh
>>>
>

Mime
View raw message